Bug 876758 - String Updates: Entitlement -> Subscription updates
String Updates: Entitlement -> Subscription updates
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: William Poteat
Tazim Kolhar
:
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2012-11-14 16:46 EST by Matt Reid
Modified: 2016-04-25 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-07 11:01:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-11-14 16:46:09 EST
Description of problem:

As part of our larger terminology updates, we're placing less emphasis on "entitlements" and referring to subscriptions instead where possible, entitlement should continue to be used in situations where we're talking about the representation of a subscription being attached to a system.

Examples!

A user manages subscriptions.
A user attaches subscriptions to a system.
A subscription attached to a system is represented as an entitlement.
A subscription covers an installed product.


#: src/main/java/org/candlepin/controller/Entitler.java:112
#, java-format
msgid "No entitlements are available from the pool with id ''{0}''."
1. "No subscriptions are available from the pool with id "{0}"."

#: src/main/java/org/candlepin/controller/Entitler.java:183
#, java-format
msgid ""
"There are not enough free entitlements available for the product ''{0}''"
2. "There are not enough free subscriptions available for the product "{0}"."

#: src/main/java/org/candlepin/resource/PoolResource.java:191
#: src/main/java/org/candlepin/resource/PoolResource.java:208
#, java-format
msgid "Entitlement Pool with ID ''{0}'' could not be found."
3. "Subscription Pool with ID "{0}" could not be found."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1093
msgid "Unable to create entitlement archive"
4. "Unable to create entitlement certificate archive"

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1354
#, java-format
msgid "No such entitlement: {0}"
5. "No such subscription: {0}"

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1464
#: src/main/java/org/candlepin/resource/EntitlementResource.java:160
#: src/main/java/org/candlepin/resource/EntitlementResource.java:210
#, java-format
msgid "Entitlement with ID ''{0}'' could not be found."
6. "Subscription with ID "{0}" could not be found."

#: src/main/java/org/candlepin/policy/js/entitlement/EntitlementRules.java:89
#, java-format
msgid "Entitlements for {0} expired on: {1}" (may have to leave this alone until we can get {0} to be a subscription instead of a product)
6. "Subscriptions for {0} expired on: {1}"

Version-Release number of selected component (if applicable):

Additional info:
Comment 1 Tom McKay 2012-12-18 09:40:08 EST
Switching product from Subscription Asset Manager to Candlepin for visibility
Comment 2 Bryan Kearney 2013-06-07 14:20:26 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 3 Tazim Kolhar 2013-08-14 05:56:05 EDT
VERIFIED :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch

# headpin -u admin -p admin system unsubscribe --uuid=a17a3cf1-e936-4f26-8dc9-4168f4c29db9 --entitlement=8a90c04e4078329801407c3627160273 --org ACME_Corporation
Entitlement with ID '8a90c04e4078329801407c3627160273' could not be found.

As described above,it should be, 

"Subscription Pool with ID "{0}" could not be found."
Comment 4 William Poteat 2013-08-23 09:11:22 EDT
Consultation with Matt Reid has led to a change in the bug.
These two should be left as they were originally.

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1354
#, java-format
msgid "No such entitlement: {0}"
5. "No such subscription: {0}"

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1464
#: src/main/java/org/candlepin/resource/EntitlementResource.java:160
#: src/main/java/org/candlepin/resource/EntitlementResource.java:210
#, java-format
msgid "Entitlement with ID ''{0}'' could not be found."
6. "Subscription with ID "{0}" could not be found."
Comment 5 William Poteat 2013-08-23 10:15:11 EDT
Also changed "No such" to "could not be found" to normalize the messages across the 2 resource classes.
Comment 6 Bryan Kearney 2014-11-07 11:01:54 EST
This is an old bug. I am closing this out. If it is still an issue, please feel free to re-open it.

Note You need to log in before you can comment on or make changes to this bug.