Bug 876764 - String Updates: consumer -> unit
String Updates: consumer -> unit
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
SAM QE List
:
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2012-11-14 17:05 EST by Matt Reid
Modified: 2016-07-22 10:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 10:39:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-11-14 17:05:15 EST
Description of problem:

As part of the terminology updates, consumer is being swapped out for unit when used generically. In cases where we know the consumer type, feel free to omit unit and just say the type.

#: src/main/java/org/candlepin/controller/Entitler.java:107
#, java-format
msgid ""
"This consumer is already subscribed to the product matching pool with id "
"''{0}''."
1. "This unit has already had the subscription matching pool ID ''{0}'' attached."

#: src/main/java/org/candlepin/controller/Entitler.java:117
#, java-format
msgid ""
"Consumers of this type are not allowed to subscribe to the pool with id "
"''{0}''."
2. "Units of this type are not allowed to attach the pool with ID ''{0}''."

#: src/main/java/org/candlepin/controller/Entitler.java:129
#, java-format
msgid "Pool not available to manifest consumers: ''{0}''."
3. "Pool not available to subscription management applications."

#: src/main/java/org/candlepin/controller/Entitler.java:137
#, java-format
msgid "Unable to entitle consumer to the pool with id ''{0}''.: {1}"
4. "Unable to attach pool with ID '{0}''.: {1}."

#: src/main/java/org/candlepin/controller/Entitler.java:179
#, java-format
msgid "This consumer is already subscribed to the product ''{0}''" (***sounds like this is in fact a product, perhaps we should change it to return the subscription in the future?)
5. "This system already has a subscription for the product ''{0}'' attached."

#: src/main/java/org/candlepin/controller/Entitler.java:187
#, java-format
msgid "Consumers of this type are not allowed to the product ''{0}''"(***sounds like this is in fact a product, perhaps we should change it to return the subscription in the future?)
6. "Units of this type are not allowed for the product ''{0}''."

#: src/main/java/org/candlepin/controller/Entitler.java:197
#, java-format
msgid "Unable to entitle consumer to the product ''{0}'': {1}" 
7. "Unable to attach subscription for the product ''{0}'': {1}."

#: src/main/java/org/candlepin/resource/ActivationKeyResource.java:145
msgid ""
"Cannot add pools restricted to consumer type 'person' to activation keys."
8. "Cannot add pools that are restricted to unit type 'person' to activation keys."

#: src/main/java/org/candlepin/resource/SubscriptionResource.java:152
#: src/main/java/org/candlepin/resource/OwnerResource.java:705
#: src/main/java/org/candlepin/resource/ConsumerResource.java:1344
#: src/main/java/org/candlepin/resource/EntitlementResource.java:132
#, java-format
msgid "No such consumer: {0}"
9. "No such unit: "{0}"."

#: src/main/java/org/candlepin/resource/OwnerResource.java:553
#: src/main/java/org/candlepin/resource/ConsumerResource.java:637
#: src/main/java/org/candlepin/model/UeberCertificateGenerator.java:122
#, java-format
msgid "No such consumer type: {0}"
10. "No such unit type: {0}."

#: src/main/java/org/candlepin/resource/OwnerResource.java:591
#: src/main/java/org/candlepin/resource/PoolResource.java:133
#, java-format
msgid "consumer: {0} not found"
11. "Unit: {0} not found."

#: src/main/java/org/candlepin/resource/OwnerResource.java:768
#: src/main/java/org/candlepin/resource/ConsumerResource.java:476
#, java-format
msgid ""
"Service level ''{0}'' is not available to consumers of organization {1}."
12. "Service level ''{0}'' is not available to units of organization {1}."

#: src/main/java/org/candlepin/resource/PoolResource.java:116
msgid "Cannot filter on both owner and consumer"
13. "Cannot filter on both owner and unit."

#: src/main/java/org/candlepin/resource/PoolResource.java:120
msgid "A consumer or owner is needed to filter on product"
14. "A unit or owner is needed to filter on installed product."

#: src/main/java/org/candlepin/resource/PoolResource.java:139
#, java-format
msgid "User {0} cannot access consumer {1}"
15. "User {0} cannot access unit {1}."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:341
msgid "A consumer type of 'person' cannot be used with activation keys"
16. "A unit type of 'person' cannot be used with activation keys."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:424
#, java-format
msgid "Problem creating consumer {0}"
17. "Problem creating unit {0}."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:540
#, java-format
msgid "User {0} has already registered a personal consumer" (***we don't use 'personal consumer' today, and probably won't in the future, maybe we can get rid of the string?)
18. -- Remove string? --

#: src/main/java/org/candlepin/resource/ConsumerResource.java:557
msgid "You must specify an organization for new consumers."
19. "You must specify an organization for new units."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1006
#, java-format
msgid "Cannot unregister {0} consumer {1} because: {2}"
20. "Cannot unregister {0} {1} because: {2}."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1426
msgid "Consumer with ID "
21. "Unit with ID "

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1550
#, java-format
msgid ""
"Consumer {0} cannot be exported. A manifest cannot be made for consumer of "
"type ''{1}''."
22. "Unit {0} cannot be exported. A manifest cannot be made for units of type {1}."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1640
#, java-format
msgid "Problem regenerating id cert for consumer {0}"
23. "Problem regenerating ID cert for unit {0}."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1679
#, java-format
msgid "The consumer with UUID {0} is not a virtual guest." 
24. "The system with UUID {0} is not a virtual guest."

#: src/main/java/org/candlepin/resource/EntitlementResource.java:113
#, java-format
msgid "Consumer: {0} has no entitlement for product {1}"
25. "Unit: {0} has no subscription for product {1}."

#: src/main/java/org/candlepin/resource/JobResource.java:108
msgid "You must specify an owner key, consumer UUID, or principal name."
26. "You must specify exactly one of owner key, unit UUID, or principal name."

#: src/main/java/org/candlepin/resource/JobResource.java:114
msgid ""
"You must specify one of owner key, consumer UUID, or principal name, but not "
"all."
27. "You must specify exactly one of owner key, unit UUID, or principal name." (***can we merge this string and the above and use the same string in both spots?)

#: src/main/java/org/candlepin/resource/ConsumerTypeResource.java:85
msgid "ConsumerType with id '"
28. "Unit type with ID "

#: src/main/java/org/candlepin/resource/ConsumerTypeResource.java:107
#, java-format
msgid "Problem creating consumertype: {0}"
29. "Problem creating unit type: {0}."

#: src/main/java/org/candlepin/resource/ConsumerTypeResource.java:128
#, java-format
msgid "Consumer Type with label {0} could not be found."
30. "Unit type with label {0} could not be found."

#: src/main/java/org/candlepin/resource/ConsumerTypeResource.java:149
#, java-format
msgid "Consumer Type with id {0} could not be found."
31. "Unit type with ID {0} could not be found."

#: src/main/java/org/candlepin/model/ConsumerCurator.java:96
#, java-format
msgid "Name of the consumer should be shorter than {0} characters." 
32. "Name of the unit must be shorter than {0} characters."

#: src/main/java/org/candlepin/model/ConsumerCurator.java:353
#, java-format
msgid "The consumer with UUID {0} is a virtual guest. It does not have guests."
33. "The system with UUID {0} is a virtual guest. It does not have guests."

#: src/main/java/org/candlepin/audit/EventAdapterImpl.java:125
#, java-format
msgid "{0} created new consumer {1}"
34. "{0} created new unit {1}"

#: src/main/java/org/candlepin/audit/EventAdapterImpl.java:126
#, java-format
msgid "{0} modified the consumer {1}"
35. "{0} modified the unit {1}"

#: src/main/java/org/candlepin/audit/EventAdapterImpl.java:127
#, java-format
msgid "{0} deleted the consumer {1}"
36. "{0} deleted the unit {1}"

#: src/main/java/org/candlepin/audit/EventAdapterImpl.java:141
#, java-format
msgid "{0} created an export for consumer {1}"
37. "{0} created an export for unit {1}"

Version-Release number of selected component (if applicable):

Additional info:
Comment 1 Tom McKay 2012-12-18 09:40:23 EST
Switching product from Subscription Asset Manager to Candlepin for visibility
Comment 2 Matt Reid 2013-07-15 11:11:38 EDT
Looking at the strings in CP again, looks like these have been added:

#: src/main/java/org/candlepin/auth/interceptor/SecurityInterceptor.java:275
#: src/main/java/org/candlepin/resteasy/interceptor/ConsumerAuth.java:55
#, java-format
msgid "Consumer {0} has been deleted"
38. "Unit {0} has been deleted"

#: src/main/java/org/candlepin/resteasy/interceptor/OAuth.java:119
#: src/main/java/org/candlepin/resteasy/interceptor/OAuth.java:155
msgid "Invalid oauth consumer or secret"
39. "Invalid oauth unit or secret"

#: src/main/java/org/candlepin/resteasy/interceptor/OAuth.java:160
msgid "Error getting oauth consumer Key"
40. "Error getting oauth unit key"

#: src/main/java/org/candlepin/controller/Entitler.java:146
#, java-format
msgid ""
"Consumer does not support instance based calculation required by pool ''{0}''"
41. "Unit does not support instance-based calculation required by pool ''{0}''"

#: src/main/java/org/candlepin/controller/Entitler.java:150
#, java-format
msgid "Consumer does not support core calculaton required by pool ''{0}''"
42. "Unit does not support core calculation required by pool ''{0}''" (please update the spelling of calculation as well)

#: src/main/java/org/candlepin/controller/Entitler.java:154
#, java-format
msgid "Consumer does not support RAM calculaton required by pool ''{0}''"
43. "Unit does not support RAM calculation required by pool ''{0}''" (please update the spelling of calculation as well)

--- other instances of consumer that don't make sense to change until the code itself is updated ---

#: src/main/java/org/candlepin/sync/Importer.java:263
msgid "The consumer_export archive has no contents"
msgstr ""

#: src/main/java/org/candlepin/sync/Importer.java:283
msgid "The archive does not contain the required consumer_export.zip file"
msgstr ""

#: src/main/java/org/candlepin/sync/Importer.java:340
msgid "The archive does not contain the required consumer_types directory"
msgstr ""

#: src/main/java/org/candlepin/sync/Importer.java:345
msgid "The archive does not contain the required consumer.json file"
msgstr ""
Comment 3 Cory Scheviak 2013-07-18 11:01:57 EDT
57b8f0ee4d951948c033f41d8b368c7364dd207c

candlepin.git
Comment 8 Mike McCune 2016-03-28 18:20:08 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Barnaby Court 2016-07-22 10:39:27 EDT
Moving to closed per the updated candlepin process for bugs that have been merged or have been taken care of.

Note You need to log in before you can comment on or make changes to this bug.