Bug 87679 - AltGr not working with BE keyboard layout
AltGr not working with BE keyboard layout
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-01 01:49 EST by Dag Wieers
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.3.0-2.90.43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-20 14:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2003-04-01 01:49:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
After upgrading a clean RH 8.0, my keyboard stopped working correctly in X. (A
Thinkpad X20)

The weird part is that AltGr is working in gdm, but isn't in Gnome nor KDE.

However in a console, it is working correctly.

The AltGr key is very important to make characters like '|', '@' and '#' (resp.
AltGr+1, AltGr+2, AltGr+3)

The XF86Config only includes:

   Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "be"
   EndSection

Which always used to worked.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Just start X with a BE keyboard
2.
3.

Severity: High (because you can't work like this !)

Additional info:
Comment 1 Need Real Name 2003-04-06 14:32:25 EDT
having a belgian keyboard here too, most altgr keys do work for me. Maybe you
should try redhat-config-keyboard
in XF86Config-4 file:

        Identifier  "Keyboard1"
        Driver      "Keyboard"
        Option      "AutoRepeat" "500 30"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "be"


Anyway i'm having another problem, this could be due to X or kbd package:
the <> key should contain the backslash, instead altgr+<> gives me: |

i need to manually setup the xmodmap to get back the backslash.


No problems in console
Comment 2 Mike A. Harris 2003-04-08 02:46:27 EDT
There's conflicting information above.  One user reporting it doesn't
work, another reporting it does work.

lethalwp: The problem you are adding to this bug report is a different
problem and warrants a separate bug report - every single bug must be
in a separate bug report.

My suggestion however, is to file both of these bugs as separate bug reports
in XFree86.org's bugzilla at:  http://bugs.xfree86.org as I am not an xkb
expert and have no idea what may or may not be wrong with the keyboard map
files, however when XFree86.org gets these types of bug reports, the
problems are usually fixed within a week quite often almost immediately,
since there are a number of experts in this area who work directly with
XFree86.org, and we can then add their fixes.

That is the fastest way to obtain a fix if there is indeed a bug.  You may
also wish instead to discuss the problem on the xfree86@xfree86.org mailing
list first in order to get a more 'official' response on the problem before
reporting it in XFree86's bugzilla.

Please add a URL here to your upstream bugzilla report and I will track
it and include their fix (if any) when available.

Thanks.


Comment 3 Dag Wieers 2003-04-08 06:47:09 EDT
Ok, I submitted my problem (#119) on XFree86's bugzilla at:

    http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=119

With some additional information, ie. I have the same problem on another desktop
in the same situation (upgrade from RH80 -> RH90), both are 102 keys keyboards.
I have no experience with fresh RH90 installs or with working RH80 -> RH90 upgrades.

A possible work-around is to enable the Gnome Keyboard Layout Switcher with the
Belgian profile.
Comment 4 Mike A. Harris 2003-04-12 11:48:25 EDT
Date: Sat, 12 Apr 2003 03:53:48 -0700 (PDT)
From: Ivan Pascal <pascal@XFree86.Org>
To: cvs-commit@XFree86.Org
List-Id: CVS commit messages from the XFree86 repository.  This is a read-only
list and you must be subscribed to it to receive messages. <cvs-commit.XFree86.Org>
Subject: CVS Update: xc (branch: trunk)
 
CVSROOT:        /home/x-cvs
Module name:    xc
Changes by:     pascal@public.xfree86.org.      03/04/12 03:53:48
 
Log message:
    92. Add keys missed in multi-layout keyboard maps: LSGT key in Belgian map
        and 'old','phonetic' variants in Armenian map (Ivan Pascal).
 
Modified files:
      xc/programs/Xserver/hw/xfree86/:
        CHANGELOG
      xc/programs/xkbcomp/symbols/pc/:
        am be
 
  Revision      Changes    Path
  3.2629        +3 -1      xc/programs/Xserver/hw/xfree86/CHANGELOG
  1.3           +108 -1    xc/programs/xkbcomp/symbols/pc/am
  1.3           +2 -1      xc/programs/xkbcomp/symbols/pc/be
Comment 5 Mike A. Harris 2003-04-12 11:50:08 EDT
I dunno if this checkin fixes this problem or not.  Ivan did ask for more
information in the upstream bug report though and no answer has been given, so
I don't know if the two issues are related, however both of them deal with
Beligium symbols.
Comment 6 Carlos Rodrigues 2003-04-13 18:47:25 EDT
I also had this problem (Portuguese layout) because I had "keycode 113 =
Mode_switch Mode_switch Multi_key" in /etc/X11/Xmodmap uncommented (I used to
need it on 8.0 to make the EuroSign work).
Comment 7 Dag Wieers 2003-04-13 19:19:28 EDT
A very useful comment by Carlos Rodrigues.

I had the same rule applied for the same reason (Euro-sign) on both my machines.
Now that I upgraded to RH9, it broke my keyboard's AltGr ;/

So I don't know if this is a bug or not, but it I don't have a working Euro-sign
now ;-)

PS I've updated the XFree86's bugzilla too.
Comment 8 Dag Wieers 2003-04-13 19:47:15 EDT
I now noticed what lethalwp@tiscali.be mentioned before.

On one of my keyboards (the big old IBM one that clicks ;p) AltGr+<> does not
work. Instead of printing a backslash (which I can't type now ;-)) it prints a
'|' (pipe symbol). On my thinkpad keyboard however, the AltGr+<> does works (and
the Euro-sign does work too !).

So, reopened again with the original (BE-centered) title ;-(
And starting the Keyboard Layout Switcher applet again.
Comment 9 Dag Wieers 2003-04-13 19:58:36 EDT
Another update. The thinkpad isn't working either (I accidentally had the Gnome
applet still running when testing). So the problem is still consistent for all
BE keyboards.
Comment 10 Dag Wieers 2003-04-14 07:04:29 EDT
Mike is right, the updates to the BE keyboard map fixes the issue.

The following fixes the problem for Belgian keyboard users (until Red Hat
releases updates to XFree86 4.3.0).

    wget -O /usr/X11R6/lib/X11/xkb/symbols/pc/be \
http://cvsweb.xfree86.org/cvsweb/~checkout~/xc/programs/xkbcomp/symbols/pc/be?content-type=text/plain
    setxkbmap "be"
Comment 11 Mike A. Harris 2003-04-18 10:34:56 EDT
I'll backport the fixes from CVS before the next 4.3.0 release.
Comment 12 Erik Poupaert 2003-04-22 10:33:28 EDT
The workaround in CVS yields "Error loading new keyboard description".
setxkbmap "be" -print | xkbcomp - $DISPLAY yields the following messages:
Warning: Attempt to alias <XFER> to non-existent key <IO1>
<NFER> to <IO3>
<AE13> to <I05>
ignored
Error: No Symbols named "ralt_switch_multikey" in the include file "level3"
Exiting
Abandoning symbols file "basic"
Abandoning symbols file "(null)"
Error: success in unknown
Couldn't write keyboard description to :0.0
Comment 13 Dag Wieers 2003-04-22 14:49:58 EDT
Well, in fact between I tested that and today (22/04/2003) that file has been
updated ;-( So you should make sure you get the v1.3 from CVS by doing:

    wget -O /usr/X11R6/lib/X11/xkb/symbols/pc/be \
http://cvsweb.xfree86.org/cvsweb/~checkout~/xc/programs/xkbcomp/symbols/pc/be?rev=1.3&content-type=text/plain

Sorry for that ;-( (I won't make that mistake again ;-))

This is what has been changed (for the worse):

-----
[root@lisse pc]# diff -u be.old be.new
--- be.old      2003-04-14 07:01:02.000000000 +0200
+++ be.new      2003-04-22 20:42:11.000000000 +0200
@@ -1,7 +1,7 @@
 
 // based on a keyboard map from an 'xkb/symbols/be' file
 //
-// $XFree86: xc/programs/xkbcomp/symbols/pc/be,v 1.3 2003/04/12 10:53:48 pascal
Exp $
+// $XFree86: xc/programs/xkbcomp/symbols/pc/be,v 1.4 2003/04/19 12:22:11 pascal
Exp $
 
 partial default alphanumeric_keys
 xkb_symbols "basic" {
@@ -42,9 +42,7 @@
     key <AB10> { [     equal,       plus,   dead_tilde, dead_abovedot] };
     key <LSGT>  { [      less,    greater,    backslash,    backslash ]        };
 
-    key <RALT>  { type[Group1]="TWO_LEVEL",
-                  [ ISO_Level3_Shift, Multi_key ]   };
-    modifier_map Mod5   { <RALT> };
+    include "level3(ralt_switch_multikey)"
 };
 
 partial alphanumeric_keys
-----
Comment 14 Mike A. Harris 2003-04-22 16:36:56 EDT
These comments need to be filed in the upstream bug report so that the
upstream maintainer is aware of the problem and can fix it in CVS.  I'll
I will do with xkb problems that are reported, is make some kind of future
attempt to backport upstream fixes that occur.  If upstream doesn't know
about an xkb issue they probably wont fix it.

Please handle xkb related problems upstream for maximum speed in bug
resolution.
Comment 15 Dag Wieers 2003-04-22 16:42:23 EDT
I did so, in the same bug-report.

    http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=119

I should have mentioned that, sorry.
Comment 16 Mike A. Harris 2003-04-22 17:36:14 EDT
Ah, I didn't check.  Just wanted to make sure your info is getting heard
by the right people.  ;o)
Comment 17 Mike A. Harris 2003-05-21 07:20:49 EDT
The upstream bug report now claims to have fixed this problem.  I will
integrate the changes into rawhide.

http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=119
Comment 18 Mike A. Harris 2003-08-16 09:59:00 EDT
Fixed in 4.3.0-19 in rawhide.

Setting bug to MODIFIED state for testing.  Please test, and set bug to RAWHIDE
if it is fixed, or ASSIGNED if still present.
Comment 19 Mike A. Harris 2003-08-26 11:38:51 EDT
Please test this and confirm as requested above.  Thanks in advance.
Comment 20 Bert de Bruijn 2003-11-20 05:47:33 EST
fixed in Red Hat 9 updates since XFree86-4.3.0-2.90.43 .

Note You need to log in before you can comment on or make changes to this bug.