Bug 876805 - RFE: Create Java command-line client
RFE: Create Java command-line client
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 21:28 EST by Sean Flanigan
Modified: 2015-08-06 01:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: zanata-cli-2.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:24:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-11-14 21:28:41 EST
Given the difficulties in maintaining the Python client, we need to provide a simple to use Java client, separate from the Maven plugin.  We actually have an command-line implementation already, named ZanataClient, but it needs to be updated, tested and maintained.

We would also need to add a shell script to invoke the Java client.

Also, we need to package the client for Fedora and EPEL.  We would need to get some of its dependencies (including the Zanata API) packaged for Fedora and/or EPEL.

An extension to this (involving more work) would be another command which maintains backwards compatibility with the old Python client's option names.
Comment 1 Sean Flanigan 2013-10-21 22:18:57 EDT
This was implemented some time ago.  (Apart from Python client option compatibility.)

The Fedora package is called zanata-client (thanks pahuang!):
  https://apps.fedoraproject.org/packages/zanata-client

Note: we weren't able to package zanata-client for EPEL because of missing/outdated dependencies.


However, we also have zanata-client-ivy for non-Fedora users:
  https://github.com/zanata/zanata-client-ivy
Comment 2 Ding-Yi Chen 2013-10-30 23:08:04 EDT
VERIFIED with zanata-cli-2.2.0

Note You need to log in before you can comment on or make changes to this bug.