Bug 876900 - webadmin: SPICE should be in upper case [TEXT]
webadmin: SPICE should be in upper case [TEXT]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.0
Assigned To: Tomas Jelinek
Yuko Katabami
virt
: i18n
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-15 04:11 EST by Yuko Katabami
Modified: 2013-06-11 05:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPICE (50.50 KB, image/png)
2013-01-28 04:23 EST, Lijun Li
no flags Details
Non Uppercase "Spice" in User Portal (259.40 KB, image/png)
2013-04-16 06:18 EDT, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10791 None None None Never
oVirt gerrit 12670 None None None Never
oVirt gerrit 14400 None None None Never

  None (edit)
Description Yuko Katabami 2012-11-15 04:11:15 EST
Description of problem:
This might be a minor point, but SPICE (the Simple Protocol for Independent Computing Environments) should be all in capital, however strings for Admin/User Portals use mixture of "SPICE", "Spice" and "spice".

Version-Release number of selected component (if applicable): 3.1


How reproducible:


Steps to Reproduce:
1. You can search them in zanata localization strings
2.
3.
  
Actual results:
mixture of "SPICE", "Spice" and "spice"

Expected results:
Should be all "SPICE"

Additional info:
Writers and translators agreed to use all uppercase for "SPICE".
To ensure the consistency between software, documentation and translation, please fix this.
Comment 1 Lijun Li 2013-01-24 03:43:47 EST
Hi Yuko,
Could you please verify it in Zanata or any steps info to verify it on the Admin/User portal with latest sf4 build?

Thanks,
Robert
Comment 3 Lijun Li 2013-01-28 04:20:25 EST
Based on Comment 2 and verified on the latest sf4 build:
# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-5.el6ev.noarch
rhevm-webadmin-portal-3.2.0-5.el6ev.noarch

Please make sure all the languages (including en_US ) the same as Ja : all 'SPICE should be in upper case' in Zanata.

Moving to ASSIGNED as still can see 'Spice' in en_US and other locales.

Please refer to the attached screenshot.
Comment 4 Lijun Li 2013-01-28 04:23:53 EST
Created attachment 688803 [details]
SPICE
Comment 17 Yuko Katabami 2013-04-16 06:18:47 EDT
Created attachment 736271 [details]
Non Uppercase "Spice" in User Portal
Comment 20 Michal Skrivanek 2013-05-03 03:48:28 EDT
I double checked the sources for those 4 above and they contain SPICE in the code. So moving this bug to i18n team.
Einav, is there anything else I may have missed?
Comment 22 Michal Skrivanek 2013-05-03 05:55:58 EDT
actually, we've found a problem still, by mistake the code was using hardcoded values instead of localized.
Moving back to virt for addressing this.
Comment 23 Tomas Jelinek 2013-05-09 02:57:54 EDT
merged u/s: ef5d4d3f54df5997f8f72eb81666f42f02f50413
Comment 25 Michal Skrivanek 2013-05-13 07:35:40 EDT
*** Bug 951282 has been marked as a duplicate of this bug. ***
Comment 26 Lijun Li 2013-05-23 02:46:55 EDT
Verified it's fixed on both rhevm-3.2 and master versions for oVirt project in Zanata.

Moving to VERIFIED.
Comment 27 Itamar Heim 2013-06-11 05:23:13 EDT
3.2 has been released
Comment 28 Itamar Heim 2013-06-11 05:44:44 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.