This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 87692 - While creating a database ext3 crashes the whole machine
While creating a database ext3 crashes the whole machine
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-01 07:31 EST by Jan Albrecht
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 11:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Albrecht 2003-04-01 07:31:08 EST
Description of problem:
Everytime when we tried to create a database on an ext3 filesystem we got 
the "kernel: ENOMEM in journal_alloc_journal_head,retrying." error and the 
machine rebooted itself.
The error could be prevented if we mounted the filesystem as an ext2 before 
creating the database.
We're using the with AS2.1 supplied cluster.

Version-Release number of selected component (if applicable):
Kernel 2.4.9-e.12summit

Database:
   Sybase  Adaptive Server Enterprise/12.5.0.1/EBF 10431 ESD#2/P/
   Linux Intel/Linux 2.2.14-5.0smp i686/rel12501/1792/32-bit/OPT/
   Mon Jul 29 22:24:47 2002 

How reproducible:
Create Database on ext3 filesystem
Steps to Reproduce:
1.
The following commands were executed:
   /* Generated on 20030326162320 by user XXXXXX*/
   create database XXXXXXX on XXXXXXXX = 2000 log on XXXXXXXX = 512
   go

   /* Generated on 20030325221626 by user XXXXXX */
   disk init name = XXXXXXXX, 
      vstart   = 0,
      physname = '/XXX/XXXXXXXX/XXXX/XXXXXX.XXXXXXXX',
      size     = 1048576,
      vdevno   = 7
   go

(sensitive Information where replaced by a 'X')

2.
The machines produces the following errors and reboots:
Mar 26 14:26:31 XXXXXXXX kernel: ENOMEM in journal_alloc_journal_head,
retrying.
Mar 26 14:26:32 XXXXXXXX portmap[17883]: connect from 172.19.232.79 to
callit(ypserv): request from unauthorized host
Mar 26 14:26:37 XXXXXXXX kernel: ENOMEM in journal_alloc_journal_head,
retrying.

    
Actual results:
To prevent this error:
- Stop Database
- remount filesystems with ext2
- create database
- restart cluster service

Expected results:
Create database on ext3 without reboot

Additional info:
A Service Request is already opened for this:
'Service Request: 230822'
Comment 1 Larry Woodman 2003-06-23 14:24:52 EDT
This problem was addressed in the latest kernel errata(e.24).

Larry Woodman
Comment 2 Suzanne Hillman 2003-10-03 11:05:59 EDT
As it's been about 3 months since this was said to have been fixed, with no
reply saying otherwise, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.