Bug 876980 - Init script: missing condrestart in 'Usage'
Summary: Init script: missing condrestart in 'Usage'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: squid
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Ondřej Pták
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-15 13:23 UTC by Dalibor Pospíšil
Modified: 2014-10-14 06:24 UTC (History)
3 users (show)

Fixed In Version: squid-3.1.10-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 06:24:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1446 normal SHIPPED_LIVE squid bug fix update 2014-10-14 01:05:47 UTC

Description Dalibor Pospíšil 2012-11-15 13:23:14 UTC
Description of problem:
condrestart is not listed in Usage massage

Version-Release number of selected component (if applicable):
squid-3.1.10-1.el6

How reproducible:
always

Steps to Reproduce:
1. check grep -e 'Usage.*condrestart' /etc/init.d/squid or run test /CoreOS/squid/Sanity/init-scripts-LSB
  
Actual results:
No condrestart in Usage message

Expected results:
        echo $"Usage: $0 {start|stop|status|reload|force-reload|restart|condrestart|try-restart|probe}"

Comment 2 RHEL Product and Program Management 2013-10-14 00:15:55 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 5 Ondřej Pták 2014-05-20 16:26:05 UTC
squid-3.1.10-20.el6_5:
----------------------
# grep -e 'Usage.*condrestart' /etc/init.d/squid
(nothing)



squid-3.1.10-22.el6:
--------------------
# grep -e 'Usage.*condrestart' /etc/init.d/squid
	echo $"Usage: $0 {start|stop|status|reload|force-reload|restart|condrestart|try-restart|probe}"

Comment 6 errata-xmlrpc 2014-10-14 06:24:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1446.html


Note You need to log in before you can comment on or make changes to this bug.