Bug 877007 - String Updates: Product string cleanups
String Updates: Product string cleanups
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: William Poteat
Og Maciel
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-15 09:17 EST by Matt Reid
Modified: 2013-10-01 06:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-11-15 09:17:32 EST
Description of problem:

There are a few strings we should think about cleaning up in candlepin around products. These just consist of updating a few subscribe/consume strings to use 'attach', and capitalizing 'id'. 

Examples!
A user attaches subscriptions to a system.
A subscription attached to a system is represented as an entitlement.
A subscription covers an installed product.



#: src/main/java/org/candlepin/controller/Entitler.java:192
#, java-format
msgid "Only virtual systems can consume the product ''{0}''"
1. "Only virtual systems can have subscription ''(0}'' attached."

#: src/main/java/org/candlepin/resource/ConsumerResource.java:1279
#, java-format
msgid "Asked to be subscribed to a product that has no pool: {0} " 
2. "Unable to attach a subscription for a product that has no pool: {0}" (***can we say that instead? current string is a bit awkward)

#: src/main/java/org/candlepin/model/EntitlementCurator.java:247
#, java-format
msgid "No product found for product id {0}"
3. "No product found for product ID {0}"

#: src/main/java/org/candlepin/audit/EventAdapterImpl.java:132
#, java-format
msgid "{0} consumed a subscription for product {1}"
4. "{0} attached a subscription for product {1}"

Version-Release number of selected component (if applicable):

Additional info:
Comment 1 Tom McKay 2012-12-18 09:40:04 EST
Switching product from Subscription Asset Manager to Candlepin for visibility
Comment 2 Bryan Kearney 2013-06-07 14:20:21 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 3 Og Maciel 2013-08-16 17:36:29 EDT
root@cloud-qe-10 candlepin-0.8.20]# grep 'subscribe' -nriI po/* | wc -l
0
[root@cloud-qe-10 candlepin-0.8.20]# grep 'attach' -nriI po/* | wc -l
186
Comment 4 Og Maciel 2013-08-16 17:39:32 EDT
[root@cloud-qe-10 candlepin-0.8.20]# grep msgid -nriI po/* | grep ' id ' | wc -l
220
Comment 5 Og Maciel 2013-08-16 17:44:19 EDT
This BZ doesn't tell QE anything about the fix. Could we get more details here please?
Comment 6 William Poteat 2013-08-19 08:46:31 EDT
The only way to confirm the fix is to check the code as listed in the bz.
Comment 8 Og Maciel 2013-08-20 10:57:08 EDT
VERIFIED:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.20-1.el6sat.noarch
* signo-katello-0.0.20-1.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 10 errata-xmlrpc 2013-10-01 06:53:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.