Bug 877032 - [JON] Cannot delete a package in a new created Repositories
[JON] Cannot delete a package in a new created Repositories
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Content (Show other bugs)
JON 3.1.1
All All
unspecified Severity high
: DR01
: JON 3.3.0
Assigned To: Lukas Krejci
Mike Foley
:
Depends On: 878596
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 10:04 EST by bkramer
Modified: 2014-11-02 23:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 877034
: 877034 878596 (view as bug list)
Environment:
Last Closed: 2014-10-30 10:03:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before-deletion (218.12 KB, image/png)
2014-08-05 08:40 EDT, Armine Hovsepyan
no flags Details
delete-button-click (332.62 KB, image/png)
2014-08-05 08:40 EDT, Armine Hovsepyan
no flags Details
after-deletion (217.78 KB, image/png)
2014-08-05 08:40 EDT, Armine Hovsepyan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 266313 None None None Never

  None (edit)
Description bkramer 2012-11-15 10:04:47 EST
Description of problem:
When Oracle is used as a backend database, attempt to delete newly created package in a repository fails with the following Exception:

Failed to delete packages: [I@7d7cec2f from repository: 10051 Error: javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not execute query

In the rhq-server-log4j.log file the following is logged:

2012-11-15 14:49:19,381 WARN  [org.hibernate.util.JDBCExceptionReporter] SQL Error: 920, SQLState: 42000
2012-11-15 14:49:19,382 ERROR [org.hibernate.util.JDBCExceptionReporter] ORA-00920: invalid relational operator


Version-Release number of selected component (if applicable):
JON 3.1.1
Oracle 

How reproducible:
always

Steps to Reproduce:
1. Navigate to Administration -> Content -> Repositories and create new repository;
2. In the new repository, create new package;
3. Attempt to delete newly created package;
  
Actual results:
Newly created package is not deleted with above Exception

Expected results:
Newly created package is successfully deleted.

Additional info:
Tested the same on Postgres - works fine.
Comment 2 Lukas Krejci 2014-05-21 09:43:51 EDT
This seems to work fine with Oracle 11g, which is the minimum supported version for JON 3.3.

Tested both with RHQ 4.12.0-SNAPSHOT and JON 3.2.1.
Comment 3 Simeon Pinder 2014-07-31 11:51:36 EDT
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993
Comment 4 Armine Hovsepyan 2014-08-05 08:40:05 EDT
Created attachment 924197 [details]
before-deletion
Comment 5 Armine Hovsepyan 2014-08-05 08:40:32 EDT
Created attachment 924198 [details]
delete-button-click
Comment 6 Armine Hovsepyan 2014-08-05 08:40:53 EDT
Created attachment 924199 [details]
after-deletion
Comment 7 Armine Hovsepyan 2014-08-05 08:41:14 EDT
verified in jon 3.3 dr1
screen-shots attached
Comment 9 Larry O'Leary 2014-10-30 10:03:58 EDT
Looks like this shouldn't have made it this far. Based on comment 2 I believe this BZ should have been CLOSED WONTFIX as it applies to 3.1 and earlier.

If anyone disagrees, please re-open the bug with your logic/reasoning.

For clarity: 

WONTFIX: This issue does not occur in Oracle Database 11g which is the earliest supported Oracle Database version beginning with JBoss ON 3.2. Oracle Database 10g was deprecated in JBoss ON 3.0 and support for it was removed in JBoss ON 3.2. As 3.2 is the latest maintenance version of JBoss ON, this issue will not be fixed for previous releases of JBoss ON.

Note You need to log in before you can comment on or make changes to this bug.