Bug 877116 - munin error with XHTML validation - graph detail pages don't display properly
Summary: munin error with XHTML validation - graph detail pages don't display properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-15 17:59 UTC by Jeff Sheltren
Modified: 2013-01-29 20:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-20 03:03:58 UTC


Attachments (Terms of Use)
Patch to HTMLConfig.pm (1.20 KB, text/plain)
2012-11-15 17:59 UTC, Jeff Sheltren
no flags Details

Description Jeff Sheltren 2012-11-15 17:59:54 UTC
Created attachment 645789 [details]
Patch to HTMLConfig.pm

Description of problem:
When browsing munin HTML for a host and clicking on a graph to see the detailed graph page (with e.g. day/week/month/year graphs), that page fails to display properly due to an XHTML validation error.

Version-Release number of selected component (if applicable):
2.0.7-1.el5

How reproducible:
Always

Steps to Reproduce:
1. Open munin host page in browser
2. Click on one of the graphs to go to a graph detail page (for example, if_eth0.html)
  
Actual results:
Page doesn't display because of XHTML parse/validate error such as:
"error on line 258 at column 67: EntityRef: expecting ';'"

Expected results:
Page should display.

Additional info:
I found a modpagespeed bug which hinted at how to fix this: http://code.google.com/p/modpagespeed/issues/detail?id=409

The problem seems to be related to using '&' in the URLs instead of '&'. I'm not an XHTML expert, so I'm just taking their word for it.  I patched /usr/lib/perl5/vendor_perl/5.8.8/Munin/Master/HTMLConfig.pm to define the URL used with '&' instead of '&' and that fixed the problem for me and pages generated in subsequent munin-cron runs displayed properly in my browser.

Attaching a patch.

Comment 1 d. johnson 2012-12-21 03:06:27 UTC
Patches welcome!

This is one of several problems with validation. If you upload your page to http://validator.w3.org/ you will discover a few more.

Better yet, submit a pull-request for it on https://github.com/munin-monitoring/munin

(Yes, I noticed this too, but then fixed too many items at once and broke CGI. I would like to see the same header/sidebar/footer on CGI pages so they match the cron-HTML page formatting.)

Comment 2 Fedora Update System 2013-01-09 19:38:21 UTC
munin-2.0.10-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.el5

Comment 3 Fedora Update System 2013-01-09 19:39:27 UTC
munin-2.0.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.el6

Comment 4 Fedora Update System 2013-01-09 19:41:20 UTC
munin-2.0.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc16

Comment 5 Fedora Update System 2013-01-09 19:42:42 UTC
munin-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc17

Comment 6 Fedora Update System 2013-01-09 19:43:53 UTC
munin-2.0.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc18

Comment 7 Fedora Update System 2013-01-10 21:31:40 UTC
Package munin-2.0.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing munin-2.0.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0593/munin-2.0.10-1.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-01-20 03:04:00 UTC
munin-2.0.10-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-01-22 03:40:29 UTC
munin-2.0.10-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-01-23 01:45:56 UTC
munin-2.0.10-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-23 01:48:54 UTC
munin-2.0.10-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-01-29 20:05:02 UTC
munin-2.0.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.