Bug 877135 - IBus icon on system tray
IBus icon on system tray
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ibus (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: fujiwara
QE Internationalization Bugs
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 14:17 EST by Carlos Henrique Castilho
Modified: 2013-06-04 01:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 01:45:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Henrique Castilho 2012-11-15 14:17:41 EST
Description of problem:
Remove IBus icon from the system tray, when rebooting the machine the icon will be shown again.

How reproducible:
Always

Steps to Reproduce:
1.Right click on IBus > Preferences;
2.Uncheck 'Show icon on system tray' checkbox;
3.Restart system;
4. Login to the system and check that the icon is in the taskbar and the 'Show icon on system tray' checkbox is uncheck.
  
Actual results:
Unchecking 'Show icon on system tray' checkbox, the icon will be removed from the system tray, although when rebooting the machine the icon shows up again and the checkbox still unchecked.

To remove the icon again is needed to check and then uncheck the checkbox, but every reboot this will still happens.

Expected results:
When unchecking the checkbox the icon should be removed even if you reboot the system.

Additional info:
None.
Comment 2 fujiwara 2012-11-16 01:19:51 EST
(In reply to comment #0)
> Description of problem:
> Remove IBus icon from the system tray, when rebooting the machine the icon
> will be shown again.
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1.Right click on IBus > Preferences;
> 2.Uncheck 'Show icon on system tray' checkbox;
> 3.Restart system;
> 4. Login to the system and check that the icon is in the taskbar and the
> 'Show icon on system tray' checkbox is uncheck.
>   
> Actual results:
> Unchecking 'Show icon on system tray' checkbox, the icon will be removed
> from the system tray, although when rebooting the machine the icon shows up
> again and the checkbox still unchecked.
> 
> To remove the icon again is needed to check and then uncheck the checkbox,
> but every reboot this will still happens.
> 
> Expected results:
> When unchecking the checkbox the icon should be removed even if you reboot
> the system.
> 
> Additional info:
> None.

I cannot reproduce your problem.
Is your show_icon_on_systray value false?

% gconftool-2 --get /desktop/ibus/panel/show_icon_on_tray
false

If you modify XIM_ARGS="--xim --verbose" in $HOME/.xinputrc or /etc/X11/xinit/xinput.d/ibus.conf , you might see any errors in $HOME/.imsettings.log .

__config_load_show_icon_on_systray() in /usr/share/ibus/ui/gtk/panel.py get the gconf value.


You can run the ibus gtk panel by manual after ibus-daemon runs.
% ps -ef | grep ibus
user $PID python /usr/share/ibus/ui/gtk/main.py
% kill $PID
% env IBUS_PREFIX=/usr python /usr/share/ibus/ui/gtk/main.py
Comment 3 John Walicki 2012-11-19 09:49:22 EST
On my system...
$ gconftool-2 --get /desktop/ibus/panel/show_icon_on_tray
No value set for `/desktop/ibus/panel/show_icon_on_tray'
Comment 4 fujiwara 2012-11-19 21:06:08 EST
(In reply to comment #3)
> On my system...
> $ gconftool-2 --get /desktop/ibus/panel/show_icon_on_tray
> No value set for `/desktop/ibus/panel/show_icon_on_tray'

Sorry, it was my typo.

% gconftool-2 --get /desktop/ibus/panel/show_icon_on_systray
false
Comment 5 fujiwara 2012-12-04 03:40:47 EST
Any updates?
Comment 6 Carlos Henrique Castilho 2012-12-11 12:48:16 EST
The ibus icon was at my systray and "Show icon on system tray" unchecked, the value was true.
# gconftool-2 --get /desktop/ibus/panel/show_icon_on_systray
true

IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-bf3bypKvMy,guid=0458b0850ae95cd877dd65b9000a97fb
GTK_IM_MODULE: 
QT_IM_MODULE: ibus
XMODIFIERS: @im=ibus
IMSETTINGS_MODULE: IBus
IMSETTINGS_INTEGRATE_DESKTOP: yes

IM-Settings-Daemon[26153]: INFO: Started IBus: process: /usr/bin/ibus-daemon -r --xim, lang=en_US.utf8, pid: 26455, id: 13, time: 2012-12-11T17:18:58.662000Z
IM-Settings-Daemon[26153]: INFO: Current IM is: IBus

It seems now that this issue is very random, when I logout it seem to be fixed.
When enabled ibus, value is true and when disabled, value is false.
Also it shows false enabling and disabling ibus at some point.
Comment 7 fujiwara 2012-12-12 06:08:49 EST
(In reply to comment #6)
> The ibus icon was at my systray and "Show icon on system tray" unchecked,
> the value was true.
> # gconftool-2 --get /desktop/ibus/panel/show_icon_on_systray
> true

I cannot reproduce your problem.

Are you able to see your problem with a new user account instead of the current user account?

When you uncheck the "Show icon on system tray" button, do you see the following dbus messages?

# cat /home/my_account/.config/ibus/bus/19c906c3e175aa938fa13dcf00000059-unix-0 
# This file is created by ibus-daemon, please do not modify it
IBUS_ADDRESS=unix:abstract=/tmp/dbus-lPAXloKlaC,guid=8a2f5eea56810212a48733380000647c

# dbus-monitor --address unix:abstract=/tmp/dbus-lPAXloKlaC,guid=8a2f5eea56810212a48733380000647c

method call sender=:1.12 -> dest=:1.1 serial=25 path=/org/freedesktop/IBus/Config; interface=(null); member=SetValue
   string "panel"
   string "show_icon_on_systray"
   boolean false
method return sender=:1.1 -> dest=:1.12 reply_serial=25
signal sender=:1.1 -> dest=(null destination) serial=311 path=/org/freedesktop/IBus/Config; interface=org.freedesktop.IBus.Config; member=ValueChanged
   string "panel"
   string "show_icon_on_systray"
   variant       boolean false
method call sender=:1.3 -> dest=:1.1 serial=242 path=/org/freedesktop/IBus/Config; interface=(null); member=GetValue
   string "panel"
   string "show_icon_on_systray"
method return sender=:1.1 -> dest=:1.3 reply_serial=242
   variant       boolean false
Comment 8 Jens Petersen 2013-03-26 02:12:27 EDT
Carlos and John, do you have any most testing results to share?
Comment 9 Jens Petersen 2013-04-09 01:41:38 EDT
IBM, are you able to follow up to comment 7?
Comment 11 RHEL Product and Program Management 2013-06-04 01:45:01 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.