Bug 877228 - Clearing the search field in workspace should keep position at last selected message
Clearing the search field in workspace should keep position at last selected ...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.1
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 20:04 EST by Hedda Peters
Modified: 2013-02-25 23:06 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121205-0926)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-11-15 20:04:57 EST
Description of problem:
When using the simple search field in the workspace, clearing that search again will drop you back at page 1 of the document. This search function needs to accomodate two different purposes though:

1) Finding a certain message within a document. It does that just fine. 
2) Navigating to a certain position within a document (e.g. because that's a chapter I need to review during proofreading; there is a whole bunch of related messages I need to compare in context, etc.) The search function doesn't serve this purpose, as it will not drop you at the position of the search result you selected.


Steps to Reproduce:
1. Open a document with several pages
2. Use simple search bar at the top to search for a term that appears later in the document, hit Enter
3. Click on the desired message from the search result from the list
4. Clear the search at the top and hit Enter again
  
Actual results:
The workspace reloads and drops you at page 1 again

Expected results:
The message you selected from the search result should keep the focus and the workspace should drop you at the appropriate page of the document, showing you all messages before/after the selected one.


Additional info:
Current workaround is using the browsers search function Ctrl-F. But since changing the default view to only 5 messages per page this became impractical, too, for obvious reasons.
Comment 1 Hedda Peters 2012-11-15 20:16:28 EST
Sorry, default view is 10 messages per page. Doesn't change the above though.
Comment 2 Patrick Huang 2012-11-29 20:51:49 EST
committed into master:
https://github.com/zanata/zanata/commit/6377e4bf6bf50205311b85005a299387a3bf2791
Comment 3 Ding-Yi Chen 2012-12-04 23:02:18 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121205-0926)

Note You need to log in before you can comment on or make changes to this bug.