This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 87733 - spurious errors from RPM on a clean RH9 install
Summary: spurious errors from RPM on a clean RH9 install
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-01 21:02 UTC by Benjamin Reed
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-02 23:57:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benjamin Reed 2003-04-01 21:02:25 UTC
Description of problem:
I'm getting errors from RPM whenever I do something like installing RPMs.

Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Every time.

Steps to Reproduce:
1. rpm --rebuilddb
    
Actual results:
[root@linux-ben root]# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy

Expected results:
No errors.  =D

Additional info:
I found some references on the RPM list that this is harmless, but anything that
spits out an error related to my RPM database scares me.  Is there something
that would cause this?  I've just done a clean install and I've barely installed
anything yet.

Comment 1 Jeff Johnson 2003-04-02 23:57:45 UTC
Yes, it's harmless. There's an out of order attempt
to remove the environment, fails just like
    rmdir /
fails, because the dbenv is still in use.

There's another bug here someplace to get this really fixed,
so I'm gonna close this bug.


Note You need to log in before you can comment on or make changes to this bug.