Bug 877337 - sudo error in l3-agent.log caused by iptables_manager.py
sudo error in l3-agent.log caused by iptables_manager.py
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: openstack-quantum (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: lpeer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-16 04:48 EST by Etsuji Nakai
Modified: 2014-10-06 05:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-06 05:09:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
removing the leading "/sbin" from iptables-save (492 bytes, patch)
2012-11-16 04:48 EST, Etsuji Nakai
no flags Details | Diff

  None (edit)
Description Etsuji Nakai 2012-11-16 04:48:40 EST
Created attachment 646268 [details]
removing the leading "/sbin" from iptables-save

The following error is on /var/log/quantum/l3-agent.log

---
RuntimeError:
Command: ['sudo', 'quantum-rootwrap', '/etc/quantum/rootwrap.conf', '/sbin/iptables-save', '-t', 'filter']
Exit code: 99
---

This is a known issue in the upstream:
https://bugs.launchpad.net/quantum/+bug/1069966

This is caused because "/sbin/iptables-save" is issued instead of "iptables-save".


My setup is:
# rpm -qf /usr/lib/python2.6/site-packages/quantum/agent/linux/iptables_manager.py
python-quantum-2012.2-2.el6.noarch
Comment 1 Gary Kotton 2012-11-16 09:05:30 EST
Hi,
The bug https://bugs.launchpad.net/quantum/+bug/1069966 has been solved upstream. The fix has been ported back to the stable folsom release. The fix is in http://github.com/openstack/quantum/commit/425e942fa28667f57282044f653a73c7fa60cfff and it will be ready in a few days when we do the new packages.
Thanks
Gary
Comment 2 Etsuji Nakai 2012-11-18 01:06:01 EST
If I'm not mistaken, the same bug seems to remain in RHOS Folsom Preview, right?

# rpm -qf /usr/lib/python2.6/site-packages/quantum/agent/linux/iptables_manager.py
python-quantum-2012.2-2.1.el6.noarch

# grep sbin /usr/lib/python2.6/site-packages/quantum/agent/linux/iptables_manager.py
        s = [('/sbin/iptables', self.ipv4)]
Comment 3 Gary Kotton 2012-11-18 01:08:05 EST
Hi,
You are not mistaken. At the moment the problem is in the preview. We are currently working on building and testing the packages with the new fix.
Thanks
Gary
Comment 5 Ihar Hrachyshka 2014-10-06 05:09:28 EDT
The issus is in Folsom. We almost already forgot that such a release existed.

Note You need to log in before you can comment on or make changes to this bug.