This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 877338 - [pt_BR][SAM Web GUI] - Upload New Manifest showing error improperly, that also not localized
[pt_BR][SAM Web GUI] - Upload New Manifest showing error improperly, that als...
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
All Linux
high Severity high
: rc
: ---
Assigned To: Tom McKay
SAM QE List
: i18n, Translation
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-16 04:48 EST by Satyabrata Maitra
Modified: 2012-11-30 10:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:56:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Manifest error message. (94.03 KB, image/png)
2012-11-16 04:48 EST, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2012-11-16 04:48:51 EST
Created attachment 646270 [details]
Manifest error message.

Description of problem:
In pt_BR locale, to import manifest, when trying to upload new manifest file (may it is not a proper manifest file or some other file) through browse, it is showing error, but the error message contains the code, instead of pure sentence based error message. And the error message is not at all translated as well.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3

How reproducible:
Always.

Steps to Reproduce:
1. Login with pt_BR locale.
2. Go to Contents tab
3. Click on Import Manifest
4. Click on Browse, on the "Upload New manifest" field.
5. Try to upload just any file.
6. Observe the error message showing.
  
Actual results:
The Erroneous error message showing which contains codes, and as well as not translated.

Expected results:
It should show the error message more meaning fully, in sentence, not having any coding in it. And it should be translated as well, in case of native language.

Additional info: Screen shot attached for reference.
Comment 1 Tom McKay 2012-11-30 10:56:07 EST
The cause of this error is fixed in a newer compose. The error message itself, being from a backend engine, will not be translated.

Note You need to log in before you can comment on or make changes to this bug.