Bug 87736 - Can't copy CD's from DVD player to CD burner
Can't copy CD's from DVD player to CD burner
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-01 17:03 EST by David Krider
Modified: 2007-04-18 12:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 11:17:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (4.18 KB, text/plain)
2003-09-20 17:25 EDT, Ben Hsu
no flags Details

  None (edit)
Description David Krider 2003-04-01 17:03:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I am trying to copy a CD from my DVD-ROM (/dev/cdrom) to my CD-RW (/dev/cdrom1).
I am using the command:

cdrecord -v -isosize dev=0,2,0 speed=12 driveropts=burnproof /dev/cdrom

I get the following errors (11 of them before it quits):

Error trying to open /dev/scd0 exclusively ... retrying in 1 second.

I am running this as root. I have tried stopping autofs, turning off all
automatic CD options in Gnome (though I run under KDE), commenting out the
drives in fstab, and changing ownership of /dev/scd0. Note that my hardware is
all SCSI (on an Adaptec 39160). Here is the supporting config info:


scsibus0:
        0,0,0     0) *
        0,1,0     1) 'TOSHIBA ' 'DVD-ROM SD-M1401' '1009' Removable CD-ROM
        0,2,0     2) 'PLEXTOR ' 'CD-R   PX-W1210S' '1.02' Removable CD-ROM
        0,3,0     3) 'IOMEGA  ' 'ZIP 100         ' 'J.03' Removable Disk
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus1:
        1,0,0   100) 'SEAGATE ' 'ST318406LW      ' '010A' Disk
        1,1,0   101) 'SEAGATE ' 'ST318406LW      ' '010A' Disk
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *


lrwxrwxrwx    1 root     root            9 Apr  1 09:31 /dev/cdrom -> /dev/scd0
lrwxrwxrwx    1 root     root            9 Apr  1 09:31 /dev/cdrom1 -> /dev/scd1
brw-------    1 kriderde disk      11,   0 Jan 30 05:24 /dev/scd0
brw-------    1 kriderde disk      11,   1 Jan 30 05:24 /dev/scd1
crw-rw----    1 root     disk      21,   0 Jan 30 05:24 /dev/sg0
crw-------    1 kriderde disk      21,   1 Jan 30 05:24 /dev/sg1
crw-rw----    1 root     disk      21,   2 Jan 30 05:24 /dev/sg2
crw-rw----    1 root     disk      21,   3 Jan 30 05:24 /dev/sg3
crw-rw----    1 root     disk      21,   4 Jan 30 05:24 /dev/sg4
crw-rw----    1 root     disk      21,   5 Jan 30 05:24 /dev/sg5

Version-Release number of selected component (if applicable):
cdrecord-2.0-6

How reproducible:
Always

Steps to Reproduce:
1. Run the command.
    

Additional info:
Comment 1 Harald Hoyer 2003-04-02 04:15:44 EST
can you try:
$ fuser /dev/scd0
and
$ lsof /dev/scd0

Comment 2 Harald Hoyer 2003-04-02 04:16:50 EST
/sbin/fuser and /usr/sbin/lsof that is
Comment 3 David Krider 2003-04-02 08:16:46 EST
While I'm trying to burn in one terminal, I get this in another. (If I try
running the fuser command outside of trying to burn, I don't get anything.)


[root@tyrannus root]# /sbin/fuser -v /dev/scd0
                     USER        PID ACCESS COMMAND
/dev/scd0            root       8012 f....  cdrecord


Doing the same thing -- running the cdrecord command -- and switching to another
teminal to run lsof, I get the following. (I did it once to grab the PID, then
grep'ed for that PID.) Note that simply grep'ing for scd0 yields only the line
included below, so no other process has it at that time. Also, lsof'ing and
grep'ing against `sg' yields nothing outside of the cdrecord command either.


[root@tyrannus root]# /usr/sbin/lsof|grep 8083
cdrecord  8083     root  cwd    DIR       8,33     4096    325121 /root
cdrecord  8083     root  rtd    DIR       8,33     4096         2 /
cdrecord  8083     root  txt    REG       8,33   276152    374709 /usr/bin/cdrecord
cdrecord  8083     root  mem    REG       8,33   103044    699083 /lib/ld-2.3.2.so
cdrecord  8083     root  mem    CHR        1,5              40187 /dev/zero
cdrecord  8083     root  mem    REG       8,33  1531064    650321
/lib/tls/libc-2.3.2.so
cdrecord  8083     root    0u   CHR      136,1                  3 /dev/pts/1
cdrecord  8083     root    1u   CHR      136,1                  3 /dev/pts/1
cdrecord  8083     root    2u   CHR      136,1                  3 /dev/pts/1
cdrecord  8083     root    3r   BLK       11,0              34676 /dev/scd0
cdrecord  8083     root    4u   CHR       21,0              38782 /dev/sg0
Comment 4 David Krider 2003-04-02 16:53:44 EST
FWIW, I ganked the original cdrtools source from the srpm and built it. It seems
to both copy .iso's and copy CD's just fine. I don't want to be ``Mr. Literal''
here, but it would seem that one of the patches being included in the rpm is
screwing with my particular setup. I'd try to figure out where the problem lies,
but the best I could probably do is try each of the patches individually and see
which one creates the problem. Let me know if this would be useful to you.
Comment 5 Harald Hoyer 2003-04-03 02:15:02 EST
well, I know which patch does affect you. And that is, what I was afraid of...
Normally the O_EXCL prevents interaction of magicdev/autorun whilst you burn
your CDs. But it seems, it cannot cope well with some scsi setups..
Comment 6 Neal D. Becker 2003-04-14 15:24:53 EDT
Yes, backing out this patch (patch6) fixes it for me! 
Comment 7 William W. Austin 2003-05-07 09:03:30 EDT
I had to debug this on an all-scsi system at home, and it was impossible to copy
a cd from a dvd drive to the cd burner.  After many hours of debugging, trying
to figure out the failures caused by patch 6, I gave up. (I had done a version
with patch 6 backed out).

When will a fixed version be available from RedHat?
Comment 8 Harald Hoyer 2003-05-07 09:19:14 EDT
could someone please send me an strace with the original cdrtools-cdrecord?
Comment 9 David Krider 2003-05-07 09:36:32 EDT
As the guy who started this bug report, I feel responsible to do an strace, but
I can't help. I'm not trying to start trouble, but I gave up on RH 9 because of
what I perceived as overall bugginess. And it appeared, from the responses I got
on the mailing list about this bug (and others I encountered), that these sorts
of things would sort of "rollingly" always be fixed in the next version. I don't
know if that's true for sure, but that's the impression I was getting, and no
one from Red Hat was saying any different. I suppose I could have just left well
enough alone here, but I wanted to go on record with the fact that these
impressions were enough to drive me away. I'm now running Other Distro 8.2 on
most of my machines, and I will be taking the rest from RH 7.3 straight to OD
8.2 as time permits. I don't mean to politicize, but, again, I feel somewhat
responsible to at least respond, since my system is a good candidate for a
platform on which to fix this bug, and I felt the next to explain the situation
a little. I'm sorry if I offend anyone.
Comment 10 Neal D. Becker 2003-05-07 09:45:24 EDT
I already fixed the problem here by backing out patch 6, so I can't help you.  The problem here 
was caused by attempting to get a lock.  Apparantly some devices don't work correctly with this.  
My device is IDE sony cdrw. 
Comment 11 Stig Nielsen 2003-08-14 01:14:09 EDT
Hi,

I just upgraded my HW, and I see the same message whenever I try to burn a CD. 
Sometimes it works though. Xcdroast is responding very slow, cat 
/var/log/messages displays:  

Aug 13 21:20:01 localhost modprobe: modprobe: Can't locate module block-major-33
Aug 13 21:20:01 localhost modprobe: modprobe: Can't locate module block-major-33
Aug 13 21:20:01 localhost modprobe: modprobe: Can't locate module block-major-34
Aug 13 21:20:01 localhost modprobe: modprobe: Can't locate module block-major-34

The CD (DVD) burner is also a Sony (CW-U10A) along with a Sony DVD reader. most 
of my hardware is new so it's at this point uncertain where the problem arise, 
but sofar I've seen the problem with only the IDE R/W attached.

scsibus0:
        0,0,0     0) 'IBM     ' 'DMVS18V         ' '0250' Disk
        0,1,0     1) 'IBM     ' 'DNES-309170W    ' 'SA30' Disk
        0,2,0     2) *
        0,3,0     3) 'PLEXTOR ' 'CD-ROM PX-40TS  ' '1.04' Removable CD-ROM
        0,4,0     4) *
        0,5,0     5) 'PLEXTOR ' 'CD-R   PX-W4220T' '1.04' Removable CD-ROM
        0,6,0     6) *
        0,7,0     7) *
scsibus1:
        1,0,0   100) 'SONY    ' 'DVD-ROM DDU1612 ' 'DYS1' Removable CD-ROM
        1,1,0   101) 'SONY    ' 'DVD RW DW-U10A  ' '1.1d' Removable CD-ROM
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *

[root@localhost etc]# fuser /dev/scd0
/dev/scd0:            4356

lsof:
COMMAND  PID USER   FD   TYPE DEVICE SIZE  NODE NAME
kdeinit 4356 stig   10r   BLK   11,1      34002 /dev/scd1

/dev/scd2 and 3 returns nothing in both cases.

My System is Soyo MB (Intel 875P chipset), Adaptec 29160. The SCSI CD-R and RW's 
are moving out when I got the new stuff to work.

Unfortunately cdrtools and related packages are not at a original state, and I 
did not go through a new system install when adding the new HW, those devices 
were just detected by kuzdu. Tomorrow I get 2 new SCSI drives and I'll try to 
install a new system and see how that goes. 
If anybody have any suggestions in that process, let me know. 
Comment 12 Ben Hsu 2003-09-20 17:25:31 EDT
Created attachment 94614 [details]
strace output
Comment 13 Ben Hsu 2003-09-20 17:26:08 EDT
I am seeing this in Red Hat 9.1 when I try to record a CD-RW. The intial burn
goes through, but when I try to blank the CD to record again I get the "Error
trying to open /dev/scd0 exclusively" error.

I did "strace cdrecord -dev=0,0,0 -blank=fast > /tmp/STRACE 2>&1". Is that what
you are looking for? The output of that command is attached
Comment 14 Ben Hsu 2003-09-21 19:33:42 EDT
Please ignore my comments above. Disabling KDE autorun fixed my problem
Comment 15 Stig Nielsen 2003-09-23 12:43:50 EDT
First of all, Sorry for the delay.  
I installed a system on my new HDD's however that did not solve the problem.
What solved all my problems (apart from the one mentioned above, my system froze
during fixating - preliminary fixed it by disabling DMA in the BIOS) was a new
xcdroast and the 2.4.20-20-9 kernel, both released just after my first post. 

I'm happy to say that my DVD/CD burning setup works flawless with Xcdroast and
DMA (not k3b - but that's an application problem) thanks to all of you.
There's a good reason our RHAT stocks are soaring :)

Comment 16 Harald Hoyer 2004-02-05 11:17:20 EST
I think the newer kernel and cdrtools fixed these problems... closing now

Note You need to log in before you can comment on or make changes to this bug.