Bug 877378 - SELinux is preventing /usr/bin/ovs-ofctl from connectto access on the unix_stream_socket /run/openvswitch/db.sock.
SELinux is preventing /usr/bin/ovs-ofctl from connectto access on the unix_st...
Status: CLOSED DUPLICATE of bug 760054
Product: Fedora
Classification: Fedora
Component: openvswitch (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Graf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-16 06:33 EST by Matthias Runge
Modified: 2014-06-18 04:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 08:51:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-11-16 06:33:31 EST
using openvswitch in connection with the quantum openvswitch plugin results in the following SELinux deny:

Additional Information:
Source Context                system_u:system_r:quantum_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                /run/openvswitch/db.sock [ unix_stream_socket ]
Source                        ovs-ofctl
Source Path                   /usr/bin/ovs-ofctl
Port                          <Unknown>
Host                          turing.berg.ol
Source RPM Packages           openvswitch-1.4.2-5.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-159.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     turing.berg.ol
Platform                      Linux turing.berg.ol 3.6.6-1.fc17.x86_64 #1 SMP
                              Mon Nov 5 21:59:35 UTC 2012 x86_64 x86_64
Alert Count                   4
First Seen                    2012-11-16 20:20:20 CET
Last Seen                     2012-11-16 20:23:34 CET
Local ID                      21262aa1-741c-422d-af24-2157c8bed7ea

Raw Audit Messages
type=AVC msg=audit(1353093814.733:1368): avc:  denied  { connectto } for  pid=5967 comm="ovs-vsctl" path="/run/openvswitch/db.sock" scontext=system_u:system_r:quantum_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=unix_stream_socket


type=SYSCALL msg=audit(1353093814.733:1368): arch=x86_64 syscall=connect success=yes exit=0 a0=3 a1=7fff1e51aad0 a2=1f a3=ffffffff items=0 ppid=5958 pid=5967 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ovs-vsctl exe=/usr/bin/ovs-vsctl subj=system_u:system_r:quantum_t:s0 key=(null)

Hash: ovs-ofctl,quantum_t,initrc_t,unix_stream_socket,connectto


[mrunge@turing horizon (master)]$ rpm -q openvswitch selinux-policy-targeted
openvswitch-1.4.2-5.fc17.x86_64
selinux-policy-targeted-3.10.0-159.fc17.noarch
Comment 1 Thomas Graf 2012-11-19 08:51:45 EST
I'm closing this as a DUP of 760054 as it obviously hasn't been properly implemented yet.

*** This bug has been marked as a duplicate of bug 760054 ***

Note You need to log in before you can comment on or make changes to this bug.