Bug 877451 - RFE: yum-like per-repo configuration for spacewalk-repo-sync
RFE: yum-like per-repo configuration for spacewalk-repo-sync
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: spacewalk-rfe 807000 space19
  Show dependency treegraph
 
Reported: 2012-11-16 10:15 EST by Milan Zazrivec
Modified: 2013-03-06 13:34 EST (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.9.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 807000
Environment:
Last Closed: 2013-03-06 13:34:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2012-11-16 10:15:28 EST
+++ This bug was initially created as a clone of Bug #807000 +++

Description of the problem:
This RFE is to request yum-like per-repo configuration for spacewalk-repo-sync.

The implementation will use already supported configuration file for
spacewalk-repo-sync:

    /etc/rhn/spacewalk-repo-sync/yum.conf

and the options will match yum's repo options as documented in yum.conf man page (for example: timeout, proxy, proxy_username, proxy_password).

Version-Release number of selected component (if applicable):
Spacewalk 1.8

How reproducible:
Deterministic

Steps to Reproduce:
1. Spacewalk contains the feature as described above
  
Actual results:
Not implemented

Expected results:
Implemented

Additional info:
N/A
Comment 1 Milan Zazrivec 2012-11-16 10:25:20 EST
spacewalk.git master: 3e7536f66d8af0e12ac233b768af41ff913a31ed
Comment 3 Milan Zazrivec 2012-11-21 10:19:07 EST
spacewalk.git master: 818f91d4ef5a3db186d1c44fffd675ff4db3524a
Comment 4 Milan Zazrivec 2012-11-21 10:35:56 EST
spacewalk.git master: a55288118f67d26d2b445220a0031f7b9c51cbb8
Comment 5 Milan Zazrivec 2012-11-22 10:21:12 EST
spacewalk.git master: 8b1bd32ad08ca31d6f4ccce98fc57567cf28fa46
Comment 6 Milan Zazrivec 2012-11-26 05:54:32 EST
spacewalk.git master: 1bfe1a375df5049c79d5a577d910bc41305ddc68
Comment 7 Milan Zazrivec 2012-11-27 04:54:30 EST
spacewalk.git master: b1abeb2c9a2a86ee2c937c7468143d39265f29af
Comment 8 Stephen Herr 2013-03-01 12:07:09 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 9 Stephen Herr 2013-03-06 13:34:33 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.