Bug 87752 - Multiheaded or xinerama support
Summary: Multiheaded or xinerama support
Status: CLOSED DUPLICATE of bug 74132
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 02:29 UTC by zweers
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (53.79 KB, image/png)
2003-10-20 20:14 UTC, Brent Fox
no flags Details

Description zweers 2003-04-02 02:29:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
I've had a multiheaded system for a while now, and everytime I upgrade I manage
to forget to save my old XF86 config file.  It would be nice if the install
would detect the fact that I have multiple graphics cards and give me the option
of setting them both up.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install the OS
2.  Start X
3.  One screen active, other screen absent
    

Actual Results:  `

Additional info:

Comment 1 Brent Fox 2003-04-02 16:00:16 UTC

*** This bug has been marked as a duplicate of 74132 ***

Comment 2 zweers 2003-04-02 20:03:02 UTC
74132 does not seem to have anything to do with multiheaded systems.  It seems
to talk about the resolutions.

I assumed that  74132 was related to what I was looking for because of the
summary until I read the comments of the problem.

I have two physically different graphics cards in my computer.  It would be nice
if redhat-config-xfree86 saw that and configured both of them so I could use
xinerama.

As a Side note, I was able to generate a new config file for the second card by
adding the BusID of the second card to my system.  I don't know if this would
work often, since my second card uses the same driver, and has a similar monitor
plugged in.  Ideally there would be a way which BusID to use when detecting the
card and settings.

I won't reopen this bug, but I'll leave it up to you to decide.

Comment 4 Brent Fox 2003-10-20 20:13:20 UTC
redhat-config-xfree86 should handle systems with one dual-head card and also
systems with two single-head cards.  You have to make sure to select the correct
secondary video card in the multihead screen.  

If you have a dual-head card, there should be only one option in the videocard
list.  If you have more than one video card, be sure to select the secondary
card from the list.  

I'll attach a screenshot showing the Second Video Card option menu.

Comment 5 Brent Fox 2003-10-20 20:14:01 UTC
Created attachment 95320 [details]
screenshot

Comment 6 David Balažic 2003-10-29 09:19:53 UTC
So redhat-config-xfree86 supports only two monitors, no more ?

I have a PCI card ( one monitor ) and an AGP card ( two monitors ).
I guess I'll have to set them up manually.


Comment 7 Brent Fox 2003-10-30 20:03:15 UTC
Yes, it supports only dualhead at the moment.  It is the most common setup
besides single-head systems.  I can extend the tool to handle more than one
monitor in the future if that becomes a common setup.

Comment 8 Red Hat Bugzilla 2006-02-21 18:52:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.