Bug 877703 - Linux Bridge NAT doesn't work due to net.bridge.bridge-nf-call-iptables=1
Linux Bridge NAT doesn't work due to net.bridge.bridge-nf-call-iptables=1
Status: CLOSED DUPLICATE of bug 877704
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-18 01:17 EST by Etsuji Nakai
Modified: 2013-07-03 22:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 07:25:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Etsuji Nakai 2012-11-18 01:17:35 EST
Description of problem:

When using Linux Bridge plugin, NAT function of the virtual router doesn't work, probably, due to "net.bridge.bridge-nf-call-iptables=1".

I'm not sure where this is set. My dirty workaround is to place the following code in /etc/rc.local.

-----------
rc=1
while [[ $rc -ne 0 ]]; do
	sysctl net.bridge.bridge-nf-call-iptables | grep "1"
	rc=$?
	sleep 5
done
sysctl -w net.bridge.bridge-nf-call-iptables=0
sysctl -w net.bridge.bridge-nf-call-ip6tables=0
sysctl -w net.bridge.bridge-nf-call-arptables=0
-----------

My setup is:
# rpm -qa | grep quantum
openstack-quantum-linuxbridge-2012.2-2.1.el6.noarch
python-quantumclient-2.1.1-0.el6.noarch
python-quantum-2012.2-2.1.el6.noarch
openstack-quantum-2012.2-2.1.el6.noarch
Comment 2 Alan Pevec 2012-11-19 07:25:04 EST

*** This bug has been marked as a duplicate of bug 877704 ***

Note You need to log in before you can comment on or make changes to this bug.