Bug 877721 - collectd 5.2 update
collectd 5.2 update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: collectd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-18 05:18 EST by Florian La Roche
Modified: 2012-12-10 02:11 EST (History)
6 users (show)

See Also:
Fixed In Version: collectd-5.2.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 02:11:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to migrate .spec to 5.2 (1.59 KB, patch)
2012-11-21 17:46 EST, Steve Traylen
no flags Details | Diff

  None (edit)
Description Florian La Roche 2012-11-18 05:18:54 EST
Description of problem:

collectd 5.2 is released upstream, even 5.1 was released in April this year.

rawhide should take in this newest release to stay current.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Traylen 2012-11-21 17:46:21 EST
Created attachment 649444 [details]
Patch to migrate .spec to 5.2

Patch to use .spec file with collectd 5.2
Comment 2 Alan Pevec 2012-11-23 13:53:10 EST
ok, what about this plan:
f17 - 4.10.x
f18 - 5.1.x
f19 - 5.2.x
el6 - 4.10.x
el6 - new package collectd5 (don't know status, I'm not involved)
Comment 3 Kevin Fenzi 2012-11-23 18:25:56 EST
Sounds fine to me... except perhaps we could get 5.2.x in f18 before release and have one less version to worry about. 

I don't know the collectd5 status off hand either. I've not had time to look at it.
Comment 4 Steve Traylen 2012-11-26 04:45:29 EST
Think there may be a small patch needed with the 5.2  packages.

The rrd module writes rrds to '/var/lib/collectd' where as the cgi
script looks for them in '/var/lib/collectd/rrd' . I suggest the latter
is more sensible.

Steve.
Comment 5 Alan Pevec 2012-11-26 07:31:16 EST
(In reply to comment #4)
> Think there may be a small patch needed with the 5.2  packages.
> 
> The rrd module writes rrds to '/var/lib/collectd' where as the cgi
> script looks for them in '/var/lib/collectd/rrd' . I suggest the latter
> is more sensible.

/etc/collectd.d/rrdtool.conf is generated in spec:
<Plugin rrdtool>
       DataDir "/var/lib/collectd/rrd"
       CacheTimeout 120
       CacheFlush   900
</Plugin>

Are you saying this doesn't have an effect in 5.2 ?
Comment 6 Alan Pevec 2012-11-26 07:37:48 EST
(In reply to comment #3)
> Sounds fine to me... except perhaps we could get 5.2.x in f18 before release
> and have one less version to worry about. 

ok,  collectd seems stable enough, although in general .0 are best to be avoided :)
It does bump libcollectdclient.so.1 but I don't think any other package links to it.
Comment 7 Alan Pevec 2012-12-02 05:36:56 EST
patch for python plugin
http://mailman.verplant.org/pipermail/collectd/2012-November/005494.html
Comment 8 Steve Traylen 2012-12-03 04:50:54 EST
(In reply to comment #5)
> > The rrd module writes rrds to '/var/lib/collectd' where as the cgi
> > script looks for them in '/var/lib/collectd/rrd' . I suggest the latter
> > is more sensible.
> 
> /etc/collectd.d/rrdtool.conf is generated in spec:
> <Plugin rrdtool>
>        DataDir "/var/lib/collectd/rrd"
>        CacheTimeout 120
>        CacheFlush   900
> </Plugin>
> 
> Are you saying this doesn't have an effect in 5.2 ?

Apologies, my mistake, I was overriding the default configuration.
Comment 9 Alan Pevec 2012-12-06 07:58:25 EST
(In reply to comment #7)
> patch for python plugin
> http://mailman.verplant.org/pipermail/collectd/2012-November/005494.html

I could not reproduce this, so I'll go ahead and update f18 to 5.2.0
Comment 10 Fedora Update System 2012-12-06 08:18:43 EST
collectd-5.2.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/collectd-5.2.0-1.fc18
Comment 11 Fedora Update System 2012-12-06 15:16:28 EST
Package collectd-5.2.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing collectd-5.2.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19865/collectd-5.2.0-1.fc18
then log in and leave karma (feedback).
Comment 12 Alan Pevec 2012-12-09 05:53:17 EST
(In reply to comment #3)
> Sounds fine to me... except perhaps we could get 5.2.x in f18 before release
> and have one less version to worry about. 

If you want to see 5.2.0 in F18 release, please test and give karma before freeze on Tuesday!

https://admin.fedoraproject.org/updates/FEDORA-2012-19865/collectd-5.2.0-1.fc18
Comment 13 Kevin Fenzi 2012-12-09 14:11:44 EST
Done. ;)
Comment 14 Fedora Update System 2012-12-10 02:11:17 EST
collectd-5.2.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.