Bug 877834 - Fontconfig warning: Having multiple values in <test> isn't supported and may not works as expected
Summary: Fontconfig warning: Having multiple values in <test> isn't supported and may...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: khmeros-fonts
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 877837 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-19 01:57 UTC by Ralf Corsepius
Modified: 2013-01-02 13:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-02 13:42:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2012-11-19 01:57:52 UTC
Description of problem:
During an attempt to upgrade a f17 installation to current f18, following the procedures described in https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18

I was facing the following yum-warning:
...
 Updating   : xorg-x11-fonts-Type1-7.5-6.fc18.noarch                                                                                                                           1162/3585 
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 29: Having multiple values in <test> isn't supported and may not works as expected
...

Comment 1 Ralf Corsepius 2012-11-19 02:14:48 UTC
*** Bug 877837 has been marked as a duplicate of this bug. ***

Comment 2 Parag Nemade 2012-11-19 05:17:57 UTC
I think I fixed this already as a fix for bug 837520. Can you check if you have khmeros-base-fonts-5.0-14.fc18.noarch installed or picked up for installation by yum?

fc-match command output results no messages on my F18 system.

Comment 3 Ralf Corsepius 2012-11-19 09:40:21 UTC
(In reply to comment #2)
> Can you check if you
> have khmeros-base-fonts-5.0-14.fc18.noarch installed or picked up for
> installation by yum?

Seems so. 

After the upgrade, I have:
# rpm -q khmeros-base-fonts
khmeros-base-fonts-5.0-14.fc18.noarch

So my guess would be, this issue is not fixed, yet, or is might be a transient issue during the upgrade.

> fc-match command output results no messages on my F18 system.
FWIW, during the upgrade, I saw a similar warning from a different *fonts package, but it rolled off the screen before I was able to write it down.
I recall the name of the fonts package having contained a "u" (*uno-fonts or similar), so I'd guess it a systematic issue in fonts packages somewhere.

Comment 4 Ralf Corsepius 2012-11-19 09:50:16 UTC
FYI: A deterministic way to reproduce this issue seem to be downgrading khmeros-base-fonts and khmeros-fonts-common on F18 to the packages from F17 triggers this warning:

# yum --releasever=17 distro-sync khmeros-base-fonts khmeros-fonts-common
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package khmeros-base-fonts.noarch 0:5.0-12.fc17 will be a downgrade
---> Package khmeros-base-fonts.noarch 0:5.0-14.fc18 will be erased
---> Package khmeros-fonts-common.noarch 0:5.0-12.fc17 will be a downgrade
---> Package khmeros-fonts-common.noarch 0:5.0-14.fc18 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================================
 Package                                              Arch                                   Version                                        Repository                              Size
=========================================================================================================================================================================================
Downgrading:
 khmeros-base-fonts                                   noarch                                 5.0-12.fc17                                    fedora                                 123 k
 khmeros-fonts-common                                 noarch                                 5.0-12.fc17                                    fedora                                 5.6 k

Transaction Summary
=========================================================================================================================================================================================
Downgrade  2 Packages

Total download size: 128 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): khmeros-fonts-common-5.0-12.fc17.noarch.rpm                                                                                                                | 5.6 kB  00:00:00     
(2/2): khmeros-base-fonts-5.0-12.fc17.noarch.rpm                                                                                                                  | 123 kB  00:00:00     
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                    168 kB/s | 128 kB     00:00     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : khmeros-fonts-common-5.0-12.fc17.noarch                                                                                                                               1/4 
  Installing : khmeros-base-fonts-5.0-12.fc17.noarch                                                                                                                                 2/4 
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 29: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 41: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 53: Having multiple values in <test> isn't supported and may not works as expected
  Cleanup    : khmeros-base-fonts-5.0-14.fc18.noarch                                                                                                                                 3/4 
  Cleanup    : khmeros-fonts-common-5.0-14.fc18.noarch                                                                                                                               4/4 
  Verifying  : khmeros-base-fonts-5.0-12.fc17.noarch                                                                                                                                 1/4 
  Verifying  : khmeros-fonts-common-5.0-12.fc17.noarch                                                                                                                               2/4 
  Verifying  : khmeros-fonts-common-5.0-14.fc18.noarch                                                                                                                               3/4 
  Verifying  : khmeros-base-fonts-5.0-14.fc18.noarch                                                                                                                                 4/4 

Removed:
  khmeros-base-fonts.noarch 0:5.0-14.fc18                                                    khmeros-fonts-common.noarch 0:5.0-14.fc18                                                   

Installed:
  khmeros-base-fonts.noarch 0:5.0-12.fc17                                                    khmeros-fonts-common.noarch 0:5.0-12.fc17                                                   

Complete!

Comment 5 Ralf Corsepius 2012-11-19 09:56:27 UTC
(In reply to comment #3)

> FWIW, during the upgrade, I saw a similar warning from a different *fonts
> package, but it rolled off the screen before I was able to write it down.
> I recall the name of the fonts package having contained a "u" (*uno-fonts or
> similar), so I'd guess it a systematic issue in fonts packages somewhere.

It's un-core-dotum-fonts - It has the same issues as khmeros-base-fonts:

# yum --releasever=17 distro-sync un-core-dotum-fonts un-core-fonts-common
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package un-core-dotum-fonts.noarch 0:1.0.2-0.18.080608.fc17 will be a downgrade
---> Package un-core-dotum-fonts.noarch 0:1.0.2-0.20.080608.fc18 will be erased
---> Package un-core-fonts-common.noarch 0:1.0.2-0.18.080608.fc17 will be a downgrade
---> Package un-core-fonts-common.noarch 0:1.0.2-0.20.080608.fc18 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================================
 Package                                            Arch                                 Version                                              Repository                            Size
=========================================================================================================================================================================================
Downgrading:
 un-core-dotum-fonts                                noarch                               1.0.2-0.18.080608.fc17                               fedora                               4.1 M
 un-core-fonts-common                               noarch                               1.0.2-0.18.080608.fc17                               fedora                                14 k

Transaction Summary
=========================================================================================================================================================================================
Downgrade  2 Packages

Total download size: 4.1 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): un-core-fonts-common-1.0.2-0.18.080608.fc17.noarch.rpm                                                                                                     |  14 kB  00:00:00     
(2/2): un-core-dotum-fonts-1.0.2-0.18.080608.fc17.noarch.rpm                                                                                                      | 4.1 MB  00:00:01     
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                    2.6 MB/s | 4.1 MB     00:01     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : un-core-fonts-common-1.0.2-0.18.080608.fc17.noarch                                                                                                                    1/4 
  Installing : un-core-dotum-fonts-1.0.2-0.18.080608.fc17.noarch                                                                                                                     2/4 
Fontconfig warning: "/etc/fonts/conf.d/65-1-un-core-dotum.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
  Cleanup    : un-core-dotum-fonts-1.0.2-0.20.080608.fc18.noarch                                                                                                                     3/4 
  Cleanup    : un-core-fonts-common-1.0.2-0.20.080608.fc18.noarch                                                                                                                    4/4 
  Verifying  : un-core-fonts-common-1.0.2-0.18.080608.fc17.noarch                                                                                                                    1/4 
  Verifying  : un-core-dotum-fonts-1.0.2-0.18.080608.fc17.noarch                                                                                                                     2/4 
  Verifying  : un-core-dotum-fonts-1.0.2-0.20.080608.fc18.noarch                                                                                                                     3/4 
  Verifying  : un-core-fonts-common-1.0.2-0.20.080608.fc18.noarch                                                                                                                    4/4 

Removed:
  un-core-dotum-fonts.noarch 0:1.0.2-0.20.080608.fc18                                        un-core-fonts-common.noarch 0:1.0.2-0.20.080608.fc18                                       

Installed:
  un-core-dotum-fonts.noarch 0:1.0.2-0.18.080608.fc17                                        un-core-fonts-common.noarch 0:1.0.2-0.18.080608.fc17                                       

Complete!

Comment 6 Parag Nemade 2012-11-19 10:26:42 UTC
The new fontconfig-2.9 release also needs to remove ambiguous rules from fontconfig files of font packages. I guess messages will appear if fontconfig is updated but font package fontconfig is not updated or viceversa.

Comment 7 Mike FABIAN 2012-11-19 10:51:31 UTC
Apparently fontconfig gets updated first.

Then some font packages get updated like xorg-x11-fonts-Type1-7.5-6.fc18.noarch
mentioned on comment#0 and as comment#3 says:

comment#3> FWIW, during the upgrade, I saw a similar warning from a different
comment#3> *fonts package,

all font packages updated between updating fontconfig and khmeros-base-fonts
will cause that warning because the khmeros-base-fonts package
which contains the .conf file causing that warning is still there.

Later, when the package khmeros-base-fonts is updated the warning
is shown one last time, from then on it is gone.

comment#3> So my guess would be, this issue is not fixed, yet, or is
comment#3> might be a transient issue during the upgrade.

It is a transient issue during the upgrade.

After the upgrade is finished, fc-cache does not show the warning anymore
which proves that it is fixed.

Comment 8 Parag Nemade 2012-12-26 09:18:36 UTC
I think this bug can be closed as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.