This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 877897 - ovirt-shell can't connect to engine when using pyphon 2.6 (httplib.HTTPSConnection source_address error)
ovirt-shell can't connect to engine when using pyphon 2.6 (httplib.HTTPSConne...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-sdk (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Michael Pasternak
infra
:
Depends On:
Blocks: 893017 915537
  Show dependency treegraph
 
Reported: 2012-11-19 03:05 EST by Andrey Gordeev
Modified: 2014-01-12 19:38 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.2.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 893017 (view as bug list)
Environment:
Last Closed: 2013-02-15 01:46:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrey Gordeev 2012-11-19 03:05:46 EST
Receive error when trying to connect to engine:

error: __init__() got an unexpected keyword argument 'source_address'

Found in versions 3.2.0.3 and 3.2.0.4

Discover that this happen because "ovirtsdk/web/httpsconnection.py" using Python 2.7 version of httplib.HTTPSConnection (with source_address parameter).

If remove source_address parameter from httplib.HTTPSConnection initialization, ovirt-shell works properly under python 2.6
Comment 1 Michael Pasternak 2012-11-21 04:48:19 EST
http://gerrit.ovirt.org/#/c/9375/

Note You need to log in before you can comment on or make changes to this bug.