Bug 877939 - [ALL_LANG][GUI] - links are not functional - "Save as Favorite" && "Clear the Search" [SAM Web GUI]
[ALL_LANG][GUI] - links are not functional - "Save as Favorite" && "Clear the...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
All Linux
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Mike McCune
Katello QA List
: i18n, Translation, Triaged
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2012-11-19 04:56 EST by Satyabrata Maitra
Modified: 2014-09-18 12:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2012-11-19 04:56:32 EST
Description of problem:
In SAM Web GUI, in en_US locale (that means it should affects all the locales), the links like "Save as Favorite" and "Clear the Search" seems not functional. If you mouse over those links, and click, nothing is happening, no action is being performed.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
Always.

Steps to Reproduce:
1. Open SAM Web GUI
2. Click on Dashboard tab
3. Look at "Latest Notification" pane.
4. Click on "More" from any notification
5. In the Search Text field, type anything relevant like "Red Hat" or "User" etc
6. And Click on Search button (A Magnifying Glass icon on the right side the 
   search field)
7. Now Click on the Drop-Down menu (on the Left side of the search field)
8. Try to Select "Save as Favorite" or "Clear the Search"
9. Observe the result.
  
Actual results:
Even if "Save as Favorite" or "Clear the Search" looks like a link, and suppose act as defined by its name, these links are not working as if these are not a link and has no action to perform.

Expected results:
The search page should be saved as favorite leaving some confirmation message to the user screen.
A Click on "Clear the search" option, should actually clear the search criteria as well as the search results.

Additional info: Actually, where ever these two option are there in the entire web page, it is not working. Given as example with the Notification. You can try with the other pages as well.
Comment 1 Lijun Li 2012-11-19 05:10:52 EST
Verified, it works in Search field for Users, Roles, Orgs, otherwise, it don't work in User Notifications, please add the functional to 'Filter...' field.
Comment 2 Satyabrata Maitra 2012-11-28 00:36:47 EST
Hi Devel

It may work in other window as described in Comment #1, but in User Notifications, the above mentioned two things does not work as described in the bug description. If these are not needed there, please remove those items from the list on User Notification window search options. This bug is yet to be verified after retesting it in the new fixed version.
Comment 3 Noriko Mizumoto 2012-12-13 01:12:02 EST
confirmed for ja-JP, those two not functional.
Comment 4 Tom McKay 2012-12-18 09:54:01 EST
Moving to CFSE to fix
Comment 9 Mike McCune 2014-03-18 13:38:50 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.