Bug 877981 - webadmin: selecting a template will change the cluster selection back to default when there is more than one cluster under the same DC
webadmin: selecting a template will change the cluster selection back to defa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.2.0
Assigned To: Michal Skrivanek
Jiri Belka
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-19 06:13 EST by Dafna Ron
Modified: 2013-06-11 04:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: sf2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 04:19:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 9512 None None None Never

  None (edit)
Description Dafna Ron 2012-11-19 06:13:56 EST
Description of problem:

I have two clusters under the same DC
when I created a new VM I select the DC -> cluster and than the template. 
after selecting the template the default (or alphabetical first) cluster is selected. 

Version-Release number of selected component (if applicable):

si24.2

How reproducible:

100%

Steps to Reproduce:
1. create a DC with two clusters + import a template
2. create a vm -> select DC -> select the second cluster on the list of clusters
3. select the template
  
Actual results:

the cluster changed to the first cluster on the list once we select the template

Expected results:

we should not automatically change the cluster configuration once selected 

Additional info:
Comment 2 Libor Spevak 2012-11-21 09:36:25 EST
After the creation of VM template, a cluster and datacenter are assigned to the new template by default.

When creating new VM based on the template, after I change the template in the dialog window, the list of clusters is updated according to it and selected cluster in the combo is the one attached to the selected VM template.

So, this is probably correct behaviour, but can be misleading. All templates are shown and new VM can be created.

But, is it better to filter the list of possible templates based on predefined cluster? It means, show only templates attached to a selected cluster?
Comment 3 Dafna Ron 2012-11-21 11:41:02 EST
templates are under a DC not a cluster and we can have several clusters under a single DC. 

if the template is not available it should be because its not under the DC, hence, if I change a DC the templates shown below will be of that new DC. 

since both clusters can use the templates we should not refresh the cluster list when we select a template only refresh it if we change a DC
Comment 4 Libor Spevak 2012-11-27 09:02:46 EST
Patch sent.
Comment 5 Libor Spevak 2012-11-27 10:54:57 EST
http://gerrit.ovirt.org/#/c/9512/
Comment 6 Libor Spevak 2012-11-29 11:28:28 EST
Merged upstream: a1c0f148b113aeec3f78c51a252da7f2ddf0bd5e
Comment 7 Jiri Belka 2013-01-25 12:18:14 EST
OK, sf4.
Comment 9 Itamar Heim 2013-06-11 04:19:51 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:23:32 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.