Bug 877998 - udev rule for hid2hci doesn't work with kernel 3.6
udev rule for hid2hci doesn't work with kernel 3.6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 07:04 EST by Alexander Holler
Modified: 2013-02-05 12:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 23:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Holler 2012-11-19 07:04:21 EST
Since kernel 3.6 the udev rule for hid2hci doesn't work anymore. At least for devices from Logitech the name of the subsystem has to be changed from usb to usbmisc. So in the file /lib/udev/rules.d/97-bluetooth-hid2hci.rules from bluez-hid2hci(-4.99-2.fc17.x86_64) the following has to be changed:

- SUBSYSTEM!="usb", GOTO="hid2hci_end"
+ SUBSYSTEM!="usbmisc", GOTO="hid2hci_end"

I don't know if that is needed for the Dell devices too.

The reason is the following commit in the mainline kernel:

7e97243c2080ecae7129e83635227fdebd4feef6

(USB: rename the usb misc class from "usb" to "usbmisc")

Regards,

Alexander
Comment 1 Alexander Holler 2012-11-19 07:24:49 EST
Using

SUBSYSTEM!="usb*", GOTO="hid2hci_end"

instead of 

SUBSYSTEM!="usbmisc", GOTO="hid2hci_end"

in my proposal above should match the subsystem usb too, if that hasn't changed for Dell devices, so using "usb*" might be the better solution. It works here too using a dongle from Logitech.
Comment 2 Alexander Holler 2012-11-20 06:24:18 EST
Btw., using "usb*" instead of "usbmisc" would work with kernels < 3.6 too, so it looks like the right choice.
Comment 3 Fedora Update System 2012-11-21 12:29:22 EST
bluez-4.101-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-4.fc18
Comment 4 Fedora Update System 2012-11-21 12:44:28 EST
bluez-4.101-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-5.fc18
Comment 5 Fedora Update System 2012-11-21 15:54:50 EST
Package bluez-4.101-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluez-4.101-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18715/bluez-4.101-4.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-07 23:32:52 EST
bluez-4.101-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-01-10 06:02:45 EST
bluez-4.101-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-6.fc18
Comment 8 Fedora Update System 2013-02-05 12:04:23 EST
bluez-4.101-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.