Bug 878028 - thumbslug can not start (missing /etc/thumbslug/client-ca.pem)
thumbslug can not start (missing /etc/thumbslug/client-ca.pem)
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: thumbslug (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-19 08:39 EST by Jakub Dorňák
Modified: 2013-02-25 10:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 09:05:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Dorňák 2012-11-19 08:39:41 EST
Description of problem:
Thumbslug does not start due to missing /etc/thumbslug/client-ca.pem.

Version-Release number of selected component (if applicable):
thumbslug-0.0.26-1.el6_3.noarch

How reproducible:


Steps to Reproduce:
1. install katello-headpin-all:
# yum install -y katello-headpin-all

2. configure sam
# katello-configure --deployment=sam --user-name='root' --user-pass='redhat' --org-name='Red_Hat'

3. reboot
  
Actual results:
thumbslug is not running,

/var/log/thumbslug/error.log says:
[main] WARN  org.candlepin.thumbslug.Main - Shutting down...
[main] INFO  org.candlepin.thumbslug.ssl.SslContextFactory - reading keystore
[main] ERROR org.candlepin.thumbslug.Main - Unable to load the ssl keystore. Check that ssl.keystore and ssl.keystore.password are set correctly.
org.candlepin.thumbslug.ssl.SslKeystoreException: Failed to initialize the server-side SSLContext.
        at org.candlepin.thumbslug.ssl.SslContextFactory.getServerContext(SslContextFactory.java:92)
        at org.candlepin.thumbslug.Main.configureSSL(Main.java:69)
        at org.candlepin.thumbslug.Main.main(Main.java:148)
Caused by: java.io.FileNotFoundException: /etc/thumbslug/client-ca.pem (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:137)
        at java.util.Scanner.<init>(Scanner.java:653)
        at org.candlepin.thumbslug.ssl.SslContextFactory.getServerContext(SslContextFactory.java:78)
        ... 2 more


After:
# cp /etc/candlepin/certs/candlepin-ca.crt /etc/thumbslug/client-ca.pem
# service thumbslug start

(found in #875876) /var/log/thumbslug/error.log says:

[main] WARN  org.candlepin.thumbslug.Main - Shutting down...
[main] INFO  org.candlepin.thumbslug.ssl.SslContextFactory - reading keystore

and thumbslug does not run.


Expected results:

thumbslug should appear running after reboot


Additional info:
Comment 2 Tom McKay 2012-11-19 09:05:52 EST
This is fixed in latest, please re-open if you encounter this error again.
Comment 3 Peter Robinson 2013-02-25 10:00:24 EST
This is still a problem with 0.0.28-1.el6_3 in conjunction with SAM 1.2.

I don't believe "upstream" is really a reasonable ticket close status for a supported product
Comment 4 Og Maciel 2013-02-25 10:43:24 EST
# service thumbslug status
thumbslug (pid  20741) is running...
# rpm -q thumbslug
thumbslug-0.0.28-1.el6_3.noarch
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.4 Beta (Santiago)
Comment 5 Tom McKay 2013-02-25 10:44:31 EST
If you wish to re-open the BZ, please include the katello-debug output as a private attachment.

Note You need to log in before you can comment on or make changes to this bug.