Bug 878088 - RFE: allow to re-define ExecStart directive
RFE: allow to re-define ExecStart directive
Status: CLOSED DUPLICATE of bug 756787
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
Unspecified All
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-11-19 11:07 EST by Honza Horak
Modified: 2012-11-19 11:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-11-19 11:16:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2012-11-19 11:07:53 EST
Description of problem:
When user wants to re-define anything in a unit file, he's supposed to create a new unit file in /etc/systemd/system/name.service and use .include directive. 

Suppose we need to add one argument to daemon binary in a service of type "Simple". Then we'd use something like this:

.include /lib/systemd/system/foo.service
ExecStart=/usr/bin/foo -new -args ...

But this is not possible, because systemd reports an error, that we want to define ExecStart twice in a service of type Simple. But we don't, we want just re-define it. systemd should be able to do that, since changing arguments of a daemon binary is quite common task.

Version-Release number of selected component (if applicable):
Comment 1 Michal Schmidt 2012-11-19 11:16:24 EST

*** This bug has been marked as a duplicate of bug 756787 ***

Note You need to log in before you can comment on or make changes to this bug.