Bug 878170 - virt-clone(1) needs to reference virt-sysprep(1)
virt-clone(1) needs to reference virt-sysprep(1)
Status: CLOSED DUPLICATE of bug 912993
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 14:26 EST by Miciah Dashiel Butler Masters
Modified: 2014-02-01 15:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-01 15:21:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miciah Dashiel Butler Masters 2012-11-19 14:26:45 EST
Description of problem:

virt-clone(1) manpage does not reference virt-sysprep(1).

Version-Release number of selected component (if applicable):


How reproducible:

I checked on RHEL6 and on the Fedora 17 manpage online:

http://linuxmanpages.net/manpages/fedora17/man1/virt-clone.1.html

Steps to Reproduce:
1. Run `man virt-clone` on the command-line.
2. Read through the manpage, or search for sysprep.
  
Actual results:

I have run virt-clone to clone a VM and am wondering why the VM sometimes ends up (for example) with eth1 configured instead of eth0.  I read the virt-clone(1) manpage but find nothing helpful in it.  I throw my hands up in despair and give up on virt-clone as a useful tool.

Expected results:

I have run virt-clone to clone a VM and have seen the aforementioned problem.  I read the virt-clone(1) manpage and realise that I should run the virt-sysprep(1) command as prior to running virt-clone.  I find virt-clone, together with virt-sysprep, to be a useful and reliable tool that makes my life easier.


Additional info:

virt-clone(1) is in the package python-virtinst.

virt-sysprep(1) is in the package libguestfs-tools.
Comment 1 Cole Robinson 2012-12-16 17:10:30 EST
Moving to the upstream tracker
Comment 2 Cole Robinson 2013-04-01 06:22:28 EDT
*** Bug 912993 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2013-04-21 15:12:26 EDT
virtinst has been merged into virt-manager.git. Moving all virtinst bugs to the virt-manager component.
Comment 4 Cole Robinson 2013-06-11 11:55:33 EDT
virt-manager clone wizard should also explicitly point to virt-sysprep and mention potential issues with our dumb clone operation, like lack of network connectivity. or maybe a wiki page somewhere
Comment 5 Cole Robinson 2014-02-01 15:21:49 EST

*** This bug has been marked as a duplicate of bug 912993 ***

Note You need to log in before you can comment on or make changes to this bug.