Bug 878184 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the directory /home/eparis/.local/share/keyrings/Default.keyring.temp-154895502.
Summary: SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:772f91d5664974a4e50435e3e07...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-19 20:01 UTC by Eric Paris
Modified: 2012-12-07 04:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-07 04:31:51 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-11-19 20:01 UTC, Eric Paris
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-11-19 20:01 UTC, Eric Paris
no flags Details

Description Eric Paris 2012-11-19 20:01:00 UTC
Additional info:
libreport version: 2.0.18
kernel:         3.6.6-9.fc18.x86_64

description:
:SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the directory /home/eparis/.local/share/keyrings/Default.keyring.temp-154895502.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gnome-keyring-daemon should be allowed write access on the Default.keyring.temp-154895502 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                staff_u:staff_r:staff_gkeyringd_t:s0-s0:c0.c1023
:Target Context                staff_u:object_r:data_home_t:s0
:Target Objects                /home/eparis/.local/share/keyrings/Default.keyring
:                              .temp-154895502 [ dir ]
:Source                        gnome-keyring-d
:Source Path                   /usr/bin/gnome-keyring-daemon
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gnome-keyring-3.6.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-50.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.6-9.fc18.x86_64 #1 SMP Fri Nov
:                              16 16:36:04 UTC 2012 x86_64 x86_64
:Alert Count                   28
:First Seen                    2012-11-16 17:32:49 EST
:Last Seen                     2012-11-19 15:00:06 EST
:Local ID                      beecc565-1982-4836-9610-c224adfd83e4
:
:Raw Audit Messages
:type=AVC msg=audit(1353355206.545:393): avc:  denied  { write } for  pid=1675 comm="gnome-keyring-d" name="keyrings" dev="dm-0" ino=288 scontext=staff_u:staff_r:staff_gkeyringd_t:s0-s0:c0.c1023 tcontext=staff_u:object_r:data_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1353355206.545:393): arch=x86_64 syscall=open success=no exit=EACCES a0=18091f0 a1=c1 a2=180 a3=32 items=1 ppid=1 pid=1675 auid=4166 uid=4166 gid=4166 euid=4166 suid=4166 fsuid=4166 egid=4166 sgid=4166 fsgid=4166 tty=(none) ses=2 comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=staff_u:staff_r:staff_gkeyringd_t:s0-s0:c0.c1023 key=(null)
:
:type=CWD msg=audit(1353355206.545:393): cwd=/var/gdm
:
:type=PATH msg=audit(1353355206.545:393): item=0 name=/home/eparis/.local/share/keyrings/Default.keyring.temp-154895502 inode=288 dev=00:22 mode=040700 ouid=4166 ogid=4166 rdev=00:00 obj=staff_u:object_r:data_home_t:s0
:
:Hash: gnome-keyring-d,staff_gkeyringd_t,data_home_t,dir,write
:
:audit2allow
:audit2allow -R

Comment 1 Eric Paris 2012-11-19 20:01:04 UTC
Created attachment 648069 [details]
File: type

Comment 2 Eric Paris 2012-11-19 20:01:06 UTC
Created attachment 648070 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-11-20 14:24:42 UTC
The problem is it got bad labeling. It should be

# matchpathcon /home/eparis/.local/share/keyrings/
/home/eparis/.local/share/keyrings	unconfined_u:object_r:gkeyringd_gnome_home_t:s0


Fixed in selinux-policy-3.11.1-55.fc18

Comment 4 Fedora Update System 2012-11-28 20:58:18 UTC
selinux-policy-3.11.1-57.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-57.fc18

Comment 5 Fedora Update System 2012-11-30 06:36:47 UTC
Package selinux-policy-3.11.1-57.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-57.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-57.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-12-02 19:30:42 UTC
Package selinux-policy-3.11.1-59.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-59.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-59.fc18
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-12-06 20:13:02 UTC
Package selinux-policy-3.11.1-60.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-60.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-60.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-12-07 04:31:52 UTC
selinux-policy-3.11.1-60.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.