Bug 8782 - Installation ignors LBA settings, LARGE settings, MS-DOS work sOK
Installation ignors LBA settings, LARGE settings, MS-DOS work sOK
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-01-23 21:13 EST by David Beecher
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-04-21 13:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Beecher 2000-01-23 21:13:18 EST
When installing RH6.0, boot from CDROM, it loads, lets me pick english, us-
keyboard, etc.  When I get to selecting WORKSTATION, SERVER, CUSTOM, and
pick WORKSTATION or SERVER it immediately reports "There is not enough
disk space for this kind of installation."  I am using a 166Mhz pentium
system, AWARD BIOS 4.51PG, genuine intel.  The BIOS recognizes the drive
type, cylinders, sectors, heads automatically.  Supports Normal (with 1023
cyl limitation) and LBA, and LARGE (which in this BIOS is the same as
LBA).  The hard disk is a CONNER CFS1621A, 1548MB w/0Kb Cache.  It is
properly recognized by the BIOS, and reports C/H/S=786/64/63 by the BIOS
with programmed IO mode 4, and it is properly recognized by LINUX while
booting off the CD (HDA: Conner Peripherals 1620Mb-CFS1621A, 1548MB w/0kB
cache, CHS=786/64/63).  It is an ATA drive and LINUX recognizes that, too.

If I do a custom installation and use either disk druid or fdisk I am
allowed to partition the drive.  Then I reboot, go into it again, all
looks well, it sees the partitions in the boot messages, but STILL reports
not enough space if I choose WORKSTATION or SERVER.  So I choose CUSTOM
and start the install.  I have it format all the partitions (for testing I
am just using the primary 4) and also check them for bad spots, all is
well.  It begins installing the software.

Installation terminates abnormally and the system is halted.

I have tried specifying CHS=786,64,63 at boot time with the lilo command.
I have tried every possible thing I can think of.  Further, I can run hard
disk diagnostics and they work fine on the entire surface.  MSDOS 6.22 and
7.0 work fine as well.  I even tried installing EZ-DRIVE, which your OS
recognizes at boot time.  Still get the problem.

Essentially it thinks the drive is only 142Mb in size and it actually
stops with a disk full problem.  If MSDOS didn't work I'd say, well, the
BIOS is implementing LBA but the drive doesn't understand it, but EZDRIVE
and the hard drive diagnostics querried the drive and they all say it
supports it.  Also, the BIOS properly recognizes all aspects of the drive.

If there is anything I can do I will.  it's a 1.6Gb drive with no defects.

Comment 1 Jay Turner 2000-02-09 18:38:59 EST
How much space does Disk Druid think the drive has if you just boot the system
without passing any kernel parameters to the installer?  A server installation
will indeed look for close to 1.8G of space, as it creates a lot of storage
space.  The workstation installation should work however.

Boot the installation, go into Disk Druid and then let me know how much space
Disk Druid thinks the drive has.  I will work to replicate this situation here
in the test lab.

Note You need to log in before you can comment on or make changes to this bug.