Bug 878291 - "DP WLK - Hot-Replace - Device Test - Verify driver support for D3 power state" job always fail on 2k864
"DP WLK - Hot-Replace - Device Test - Verify driver support for D3 power stat...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 22:41 EST by Mike Cao
Modified: 2013-02-21 05:42 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:42:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpk file (1.24 MB, application/octet-stream)
2012-11-19 22:46 EST, Mike Cao
no flags Details
Event_System_log (68.00 KB, application/octet-stream)
2012-11-20 22:01 EST, Min Deng
no flags Details
CPK-48 (219.41 KB, application/octet-stream)
2012-11-28 04:51 EST, Min Deng
no flags Details
SETUP (94 bytes, application/octet-stream)
2012-11-28 04:53 EST, Min Deng
no flags Details
eventlog (20.07 MB, application/octet-stream)
2012-11-28 04:59 EST, Min Deng
no flags Details

  None (edit)
Description Mike Cao 2012-11-19 22:41:45 EST
Description of problem:


Version-Release number of selected component (if applicable):
2.6.32-338.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64
virtio-win-prewhql-45


How reproducible:
100%

Steps to Reproduce:
1.start win2k8-64 guest w/ virito serial
2."DP WLK - Hot-Replace - Device Test - Verify driver support for D3 power state" job

  
Actual results:
job always fail w/ unexpected reboot 

Expected results:
job pass

Additional info:
job can pass w/ build 43 ,it it is a regression and testblocker
Comment 2 Mike Cao 2012-11-19 22:46:25 EST
Created attachment 648251 [details]
cpk file
Comment 4 Yan Vugenfirer 2012-11-20 04:37:08 EST
Hi Mike,

The VM probably crashed - can you check if you can fetch the memory dump from VM if possible?

Thanks,
Yan.
Comment 5 Mike Cao 2012-11-20 08:34:17 EST
(In reply to comment #4)
> Hi Mike,
> 
> The VM probably crashed - can you check if you can fetch the memory dump
> from VM if possible?
> 
> Thanks,
> Yan.

Hi, That's also my assumption ,But I check the VM all the time when job running ,no crash occurs
Comment 6 Mike Cao 2012-11-20 08:50:31 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Hi Mike,
> > 
> > The VM probably crashed - can you check if you can fetch the memory dump
> > from VM if possible?
> > 
> > Thanks,
> > Yan.
> 
> Hi, That's also my assumption ,But I check the VM all the time when job
> running ,no crash occurs

more info:

When this job running ,file in C:\ named SimpleIO.tmp created,but the size of this file always be 0kb .I did not see any jobs running .after 10 mins ,guest will reset .then the job shows fail.

also hit this issue on windows server 2k8R2 .
We tried this job both on AD environment and Workgroup environment ,both hit this issue.
We did not hit this issue on virtio-win-prewhql-43
Comment 7 Gal Hammer 2012-11-20 10:14:00 EST
I'm trying to reproduce but it might take some time to have the test running.

In the mean while can you please add the VM's command line and check if there are minidumps or something that might be useful in the event viewer?

Thanks in advanced.
Comment 9 Min Deng 2012-11-20 22:01:12 EST
Created attachment 648996 [details]
Event_System_log
Comment 11 Mike Cao 2012-11-27 05:36:34 EST
QE can reproduce this issue on build 37 , 45
can not reproduce this issue on build 43
Comment 13 Ronen Hod 2012-11-27 10:12:23 EST
In build 48, we did some rollbacks and tried a different approach to the serial bug fix. Let's hope that it works.
Comment 14 Gal Hammer 2012-11-27 11:13:21 EST
While trying to reproduce qemu crashed with "Guest moved used index from 2 to 1" error message. This is might explain why there is no crash dump. Is this what happened to you too?
Comment 15 Mike Cao 2012-11-28 00:19:32 EST
(In reply to comment #14)
> While trying to reproduce qemu crashed with "Guest moved used index from 2
> to 1" error message. This is might explain why there is no crash dump. Is
> this what happened to you too?

Yes .
QE run command in "screen" terminal ,we usually detach the screen terminal when job running . So sorry for missing this important infomation .

Mike
Comment 16 Mike Cao 2012-11-28 01:18:23 EST
Still can reproduce this issue on build 48

Mike
Comment 17 Mike Cao 2012-11-28 03:23:38 EST
More Results for this issue

Can reproduce this issue on build 41 ,can not reproduce this issue on build 42
Seems following patch fix this issue on build 42

commit 123f635776a72fba7dd7a020a7670e2468b40de8
Author: Vadim Rozenfeld <vrozenfe@redhat.com>
Date:   Tue Oct 30 12:55:31 2012 +0200

    [vioser] BZ840911 - move VIRTIO_CONSOLE_PORT_OPEN control message to
    VIOSerialEvtDeviceD0ExitPreInterruptsDisabled callback


While it is regressed from build 45 again.

Mike
Comment 18 Mike Cao 2012-11-28 03:28:30 EST
Job logs (pass) on build 42 ,

Runtime 11/28/2012 8:10:03.765 AM _  
Runtime Index:   493776724 
Machine:   2K8-64-48 
Process Name:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRunB8B22C51-0596-4660-AABA-8A9C14ECB6F3\pnpcpu.exe 
Process ID:   2788 
Thread ID:   2792 
Context _  _  
Context Index:   3533954410 
Current:   Check Basic Requirements. 
Parent:   WTTLOG 
Start Test 11/28/2012 8:10:03.765 AM Check Basic Requirements. 
End Test 11/28/2012 8:10:03.765 AM Check Basic Requirements. 
Result:   Pass 
Repro:   pnpcpu.exe -logoreplace 
Context _  _  
Context Index:   384048256 
Current:   WTTLOG 
Parent:   ROOT 
Message 11/28/2012 8:10:03.765 AM Dynamic Partitioning is supported on this sku. 
Message 11/28/2012 8:10:03.765 AM Pausing for 5 minutes, before performing replace... 
Context _  _  
Context Index:   1523297033 
Current:   Logo Replace. 
Parent:   WTTLOG 
Start Test 11/28/2012 8:15:03.765 AM Logo Replace. 
End Test 11/28/2012 8:15:06.765 AM Logo Replace. 
Result:   Pass 
Repro:   pnpcpu.exe -logoreplace 
Pass/Fail Result Rollup Counts 11/28/2012 8:15:06.765 AM _  
Total:   2 
Passed:   2 
Failed:   0 
Blocked:   0 
Warned:   0 
Skipped:   0 

HTH,
Mike
Comment 19 Vadim Rozenfeld 2012-11-28 04:31:56 EST
(In reply to comment #16)
> Still can reproduce this issue on build 48
> 
> Mike

Hi Mike,
Can yo please post cpk and setupapi files?
Thank you,
Vadim.
Comment 20 Mike Cao 2012-11-28 04:37:41 EST
(In reply to comment #19)
> (In reply to comment #16)
> > Still can reproduce this issue on build 48
> > 
> > Mike
> 
> Hi Mike,
> Can yo please post cpk and setupapi files?
> Thank you,
> Vadim.

Vadim ,you mean build 48 ?
Comment 21 Min Deng 2012-11-28 04:50:27 EST
(In reply to comment #19)
> (In reply to comment #16)
> > Still can reproduce this issue on build 48
> > 
> > Mike
> 
> Hi Mike,
> Can yo please post cpk and setupapi files?
> Thank you,
> Vadim.

Hi Vadim,

   Please see the attachments for your request.

Best Regards
Min
Comment 22 Min Deng 2012-11-28 04:51:51 EST
Created attachment 653396 [details]
CPK-48
Comment 23 Min Deng 2012-11-28 04:53:48 EST
Created attachment 653398 [details]
SETUP
Comment 24 Min Deng 2012-11-28 04:59:23 EST
Created attachment 653400 [details]
eventlog
Comment 25 Vadim Rozenfeld 2012-11-28 06:48:35 EST
(In reply to comment #24)
> Created attachment 653400 [details]
> eventlog

Thanks.
Comment 26 Mike Cao 2012-11-30 22:36:53 EST
Verified this bug on virito-win-prewhql-49 ,this job can pass

Based on above ,this issue has been fix ald ,move status to verified .
Comment 27 errata-xmlrpc 2013-02-21 05:42:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.