Bug 878325 - Can not query this bugzilla instance for 'Bugzilla.time'
Can not query this bugzilla instance for 'Bugzilla.time'
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.2
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 01:18 EST by Steve Kowalik
Modified: 2014-10-12 18:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-26 19:06:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 598575 None None None Never

  None (edit)
Description Steve Kowalik 2012-11-20 01:18:52 EST
Description of problem:

Hi,

Currently querying this bugzilla instance for the method call of 'Bugzilla.time' over XMLRPC raises a fault with a Perl error.

Version-Release number of selected component (if applicable): 4.2.4-6

How reproducible:

Every time.

Steps to Reproduce:
1. Download script at http://pastebin.ubuntu.com/1371851/
2. Run it.
  
Actual results:

A fault occurred
Fault code: -32000
Cannot compare a datetime to a regular scalar at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DateTime.pm line 1385.

Expected results:

{'tz_name': 'UTC', 'tz_short_name': 'UTC', 'tz_offset': '+0000', 'web_time_utc': <DateTime '20121120T06:08:24' at 2349e60>, 'db_time': <DateTime '20121120T06:08:24' at 2349dd0>, 'web_time': <DateTime '20121120T06:08:24' at 2349e18>}

Additional info:
Comment 1 Simon Green 2012-12-16 22:50:15 EST
Possibly an upstream issue too.
Comment 2 Simon Green 2013-01-09 20:11:18 EST
It seems to work fine on our RHEL 6 based Bugzilla server, but not the RHEL 5 ones (like production and partner-bugzilla).

  -- simon
Comment 4 Steve Kowalik 2013-01-10 02:24:25 EST
I don't think this is WONTFIX, since there is a fix of sorts, since it works on the RHEL 6 based server.

Moreover, it not being deployed to production is also no reason to close the bug as WONTFIX either. Bugzilla is a webservice, if the fix isn't deployed, it isn't really fixed.
Comment 5 Simon Green 2013-01-10 05:26:27 EST
Hi Steve.

There was a private comment on this bug that explained that we are planning to move to RHEL 6 server soon. I'm happy to keep this bug open until then if you want. However, we won't be fixing the issue until we move to RHEL 6 server.
Comment 6 Xin Zhang 2013-03-21 03:15:37 EDT
Return to Perl error when calling Bugzilla.time and Bugzilla.last_audit_time over XMLRPC.

version:4.4.rc2-2.b01
test env:https://bzweb01-qe.app.eng.rdu.redhat.com/

When calling these two methods over XMLRPC, it will return to  <Fault -32000: 'Cannot compare a datetime to a regular scalar at /usr/lib/perl5/5.8.8/CGI/Carp.pm line 314.\n'>

While when doing the same operation in https://bzweb01-devel.app.eng.rdu.redhat.com/(version 4.4.rc2-2.b01),it will return to the expected info:
xmlrpc.Bugzilla.time()
{'db_time': <DateTime '20130321T07:11:56' at 9efd48c>,
 'tz_name': 'UTC',
 'tz_offset': '+0000',
 'tz_short_name': 'UTC',
 'web_time': <DateTime '20130321T07:11:56' at 9efd44c>,
 'web_time_utc': <DateTime '20130321T07:11:56' at 9efd26c>}

xmlrpc.Bugzilla.last_audit_time({'class':['Bugzilla:Product']})
{'last_audit_time': <DateTime '20130226T12:58:34' at 9ef964c>}
Comment 8 Jason McDonald 2014-02-05 01:15:16 EST
This should be fixed when the production system moves to RHEL6.
Comment 9 Simon Green 2014-05-26 19:06:38 EDT
We migrated to RHEL 6 last week, and Bugzilla.time now works as expected. The pastebin link is no longer valid, but I did this this using JSONRPC and a Perl script.

Note You need to log in before you can comment on or make changes to this bug.