Bug 878397 - allow all in one to skip rpm installation of vdsm
allow all in one to skip rpm installation of vdsm
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Alon Bar-Lev
integration
: Improvement
Depends On:
Blocks: bootstrap-rewrite
  Show dependency treegraph
 
Reported: 2012-11-20 06:07 EST by Itamar Heim
Modified: 2013-02-15 01:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2012-11-20 06:07:07 EST
since allineone brings all dependnecies of vdsm at yum install phase as deps of the allinone plugin rpm, there is no need for the add host phase to re-install them.
should use a bootstrap config that will skip the bootstrap package installation
Comment 1 Alon Bar-Lev 2012-11-20 16:37:57 EST
commit 519e048f158dd1bb6c4025fbfc027cb44a6f9ee6
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Tue Nov 20 23:20:39 2012 +0200

    packaging: all-in-one: depend on ovirt-host-deploy-offline
    
    The ovirt-host-deploy-offline configures the ovirt-host-deploy for
    offline mode, and contains all relevant dependencies.
    
    Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=878397
    Change-Id: If145380ebcd3ab114197a931d4a7ce256c3ed78d
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

http://gerrit.ovirt.org/9371
Comment 2 Itamar Heim 2013-01-16 11:10:33 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.