This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 878425 - virt-manager: use virDomainMemoryStats for memory graph
virt-manager: use virDomainMemoryStats for memory graph
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On: 963488
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 06:57 EST by Martin Häcker
Modified: 2014-01-15 04:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 16:08:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Häcker 2012-11-20 06:57:16 EST
Description of problem:
When viewing the virt-manager gui's  machine info page and the performance overview on that it does show statistics of the host system for memory and cpu load.

This is not what I as a user expect when viewing that data at that place as the GUI strongly suggests that this is data about that selected VM.


Version-Release number of selected component (if applicable):


How reproducible:
1. Open a Machine
2. go to the Details tab
3. select the Performance entry from the sidebar on the left
4. look at the data

Actual results:
Shows data from the host system

Expected results:
Should show data about / from the guest system

Additional info:
Took me about half a year to figure that out while casually glancing at this screen now and then to understand how my vms are doing. All the while I missed a serious out of memory situation on one of our vms due to this missunderstanding - that would have been very easy to spot had the info been what I expected it to be.
Comment 1 Tadej Janež 2013-04-22 08:29:34 EDT
Agreed, fixing this would be a very nice enhancement to virt-manager.
Comment 2 Cole Robinson 2013-04-29 12:51:50 EDT
Applied Tadej's patch upstream.

However in response to comment 1, those graphs still don't show memory usage from inside the guest, that's a more involved fix which requires using newer libvirt APIs. Moving this bug to the upstream tracker for that bit.
Comment 3 Cole Robinson 2014-01-14 16:08:47 EST
True memory usage graphing is upstream now
Comment 4 Martin Häcker 2014-01-15 04:06:24 EST
Thats great! :-)

Note You need to log in before you can comment on or make changes to this bug.