Bug 878451 - [RHEVM] [webadmin] [TEXT] extend error for pinned host missing non required network
[RHEVM] [webadmin] [TEXT] extend error for pinned host missing non required n...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: 3.2.0
Assigned To: Alona Kaplan
Martin Pavlik
network
:
Depends On:
Blocks: 915537 922807 948448
  Show dependency treegraph
 
Reported: 2012-11-20 08:21 EST by Martin Pavlik
Modified: 2016-02-10 14:50 EST (History)
11 users (show)

See Also:
Fixed In Version: sf10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
engine.log (123.00 KB, application/x-gzip)
2012-11-20 08:21 EST, Martin Pavlik
no flags Details
screenshot 1 (177.12 KB, image/png)
2012-11-20 08:22 EST, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11337 None None None Never
oVirt gerrit 11338 None None None Never
oVirt gerrit 11453 None None None Never
oVirt gerrit 12460 None None None Never

  None (edit)
Description Martin Pavlik 2012-11-20 08:21:40 EST
Created attachment 648461 [details]
engine.log

Description of problem:
If VM has attached certain non-required network and user tries to run the VM pinned to specific host which does not have the non-required network. Folowing error message appears.

Error while executing action: Cannot run VM. VM is pinned to a specific Host but cannot run on it due to:
Invalid Host status or not enough free resources on it.
You may free resources on the Host by migrating other VMs.

It doesn t give a clue to user what is actually wrong.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.1.0-30.el6ev 

How reproducible:
100%

Steps to Reproduce:
Two Hosts (Host1, Host2)

Actions
1. Create logcial network and attach to cluster
2. configure new network as required=false
3. add network only to one host (Host1)
4. create VM, attach new network to VM, try to start VM on the Host2
 

Actual results:
Error while executing action: Cannot run VM. VM is pinned to a specific Host but cannot run on it due to:
Invalid Host status or not enough free resources on it.
You may free resources on the Host by migrating other VMs.


Expected results:
Error while executing action: Cannot run VM. VM is pinned to a specific Host but cannot run on it due to:
Invalid Host status or not enough free resources on it. You may free resources on the Host by migrating other VMs.
or
Network required by VM is not attached to the host.

Additional info:
2012-11-20 14:12:19,028 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (ajp-/127.0.0.1:8702-1) CanDoAction of action RunVm failed. Reasons:VAR__ACTION__RUN,VAR__TYPE__VM,VM_PINNED_TO_HOST_CANNOT_RUN_ON_THE_DEFAULT_VDS
Comment 1 Martin Pavlik 2012-11-20 08:22:19 EST
Created attachment 648462 [details]
screenshot 1
Comment 2 Alona Kaplan 2013-01-28 05:24:44 EST
http://gerrit.ovirt.org/#/c/11338/
Comment 3 Martin Pavlik 2013-02-18 08:25:59 EST
Error message now says this:

RHEL64:

    Cannot run VM. VM is pinned to Host 'dell-06' but cannot run on it.
    Cannot run VM. There are no available running Hosts with all the networks used by the VM.

The last sentence is false and confusing. There is at least one host with all networks used, but VM is not pinned to it. 

I would suggest to rephrase it to something like this:

RHEL64:

    Cannot run VM. VM is pinned to Host 'dell-06' but cannot run on it. Host does not have attached all networks used by VM.
Comment 4 Simon Grinberg 2013-02-26 10:22:46 EST
(In reply to comment #3)
>     Cannot run VM. VM is pinned to Host 'dell-06' but cannot run on it. Host
> does not have attached all networks used by VM.

The infrastructure does not allow for it, since the second line is a generic message provided after searching all available host provided to the scheduler and validated each hosts one by one. The fact the list of hosts equals 1 does not interest the generic function. The first line was added as a modifier on top of that. 

What can be done is to make it a bit clearer:
    Cannot run VM. There are no available running Hosts with all the networks used by the VM. 
    Note: The VM is pinned to Host 'dell-06' but cannot run on it.

This makes it clear that the issue is related to a specific host while the first is a generic error message.
Comment 5 Itamar Heim 2013-06-11 04:46:19 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:46:19 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:46:38 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:52:07 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:23:04 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.