Bug 878495 - [webadmin] Confusing text when importing a VM and same VM name already exists in environment - Clone
[webadmin] Confusing text when importing a VM and same VM name already exists...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.0
Assigned To: Arik
Jiri Belka
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-20 09:48 EST by Jiri Belka
Modified: 2013-06-11 05:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: sf6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 05:12:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Current dialog (113.62 KB, image/png)
2013-01-14 04:03 EST, Arik
no flags Details
Proposed dialog (124.17 KB, image/png)
2013-01-14 04:04 EST, Arik
no flags Details
modified dialog for vm import conflict (138.69 KB, image/png)
2013-01-21 07:01 EST, Arik
no flags Details
modified dialog for template import conflict (136.49 KB, image/png)
2013-01-21 07:02 EST, Arik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11435 None None None Never

  None (edit)
Description Jiri Belka 2012-11-20 09:48:36 EST
Description of problem:

When importing a VM and the VM name already exists in the environment (export-> then import it back), popup dialog says 'There is already a VM(s) with the same name (win2008_32bit) select: Don't Import/Clone'. The word 'Clone' is confusing, the content of the work 'Clone' is to make a copy of already existing thing for testing but in this context it is trying to tell us you can change name not to have duplicate VM names. Please invent other naming which would be more clear.

Version-Release number of selected component (if applicable):

SI24.3

How reproducible:

Always.

Steps to Reproduce:
1. Make a VM
2. Export
3. Import while original VM still exists in the environment
  
Actual results:

Popup says 'Clone' in one of the possibilities.

Expected results:

Maybe better would be 'Rename imported' or something like that.
Additional info:
Comment 1 Arik 2013-01-14 04:03:42 EST
Created attachment 678116 [details]
Current dialog
Comment 2 Arik 2013-01-14 04:04:52 EST
Created attachment 678117 [details]
Proposed dialog
Comment 3 Arik 2013-01-14 04:16:06 EST
Simon/Einav - please check the proposed dialog (attachment 678117 [details]), there are two changes comparing to the current dialog (attachment 6788116):

1. The first statement in the dialog - we open this kind of dialog for each VM with an already existing name, so I think "There already exists VM named: <vm_name>" is better than the current sentence: "Please select a name for the cloned VM(s) (<vm_name>)" + it doesn't contain the word "cloned"

2. "Cloned" is renamed to "Choose different name for the imported VM"

Is the proposed dialog OK ?
Comment 4 Simon Grinberg 2013-01-14 06:57:24 EST
We are not just changing the name we also:
1. Change the UUID
2. Collapse snapshots into a new image. 

The above is a clone procedure same as you do when you clone from template. 
We need to make that clear, but I understand why just clone may be confusing.

So please add near the clone option saying "Import as a new cloned virtual machine (New name, IDs, and collapsed disk images)"

Please also explain that it's wither that or the suffix option - it's not clear
Comment 5 Jiri Belka 2013-01-14 07:24:28 EST
The user trying to import his VM from export domain doesn't care about what is happening in background, that's why word 'clone' in this context is confusing. I'm OK with 'Proposed dialog' screenshot.
Comment 6 Simon Grinberg 2013-01-15 05:59:15 EST
(In reply to comment #5)
> The user trying to import his VM from export domain doesn't care about what
> is happening in background, that's why word 'clone' in this context is
> confusing. I'm OK with 'Proposed dialog' screenshot.

Well product management is not OK with the change, the fact that it's satisfies your single use case does not mean it satisfies all.

Just to fix the sum up of changes, we are not just changing the name we also:
1. Change the UUID - <visible to advanced/api users 
2. Collapse snapshots into a new image - Immediately impacts storage if the VM is based on template and advance user api user will notice.
3. Changes the virtual NICs MAC addresses - Visible to the VM user and may impact ifcfg scripts. 

You raised a valid concern about clarity of the current dialogue however, it is a clone by definition and should be state as such, period. We can only do better by informing what exactly we are going to do - so change name is definitely a misleading term. 

The same user when he notices the changes will immediately call support with questions. Farther more the clarification is important since the user may not want the above to happen and may prefer not to import or to delete the existing VM before importing  

Let's say: 
"Import as cloned. Changing name, MAC addresses, and cloning all disks removing all snapshots."

UUID, is not interesting in this message, it's implied. 

Livnat, Ayal, is this all we do or did I miss something?
Comment 7 Arik 2013-01-21 07:01:51 EST
Created attachment 684246 [details]
modified dialog for vm import conflict
Comment 8 Arik 2013-01-21 07:02:23 EST
Created attachment 684247 [details]
modified dialog for template import conflict
Comment 9 Arik 2013-01-21 07:05:19 EST
Simon, can you please check the two dialogs above (one for import VM conflict, and one for import Template conflict), if they're OK ?
Comment 10 Simon Grinberg 2013-01-21 12:20:36 EST
(In reply to comment #9)
> Simon, can you please check the two dialogs above (one for import VM
> conflict, 

Import VM is OK.
I would drop the long description one line down to reduce the width of the dialogue. 

> and one for import Template conflict), if they're OK ?

We did not discuss import of existing templates in this thread.

This is a different discussion since there is an impact on VMs that the template is their parent image, please do not change anything yet and let's discuss over a new BZ - please describe current behavior for already existing:

1. Template with the same UUID 
2. Template with same name but different UUID  

We need to decide what to do with each - maybe we already have the right behavior.
Comment 12 Jiri Belka 2013-02-07 07:16:32 EST
ok, sf6.
Comment 13 Itamar Heim 2013-06-11 05:12:25 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:39:24 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.