Bug 87851 - (xchat2) This is the version police
This is the version police
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 88427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 00:31 EST by Trever Adams
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 19:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2003-04-03 00:31:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I noticed in Phoebe and Rawhide that xchat is still 1.8.11.  This doesn't seem
right as Xchat 2.0 seems to have all features of 1.8.11 and is more up to date
for the destkop.  I am sure there might be reason with some software to not
include updated versions, however, Xchat does seem to be stable and does seem to
have released 2.0 (in february) in time for release in RH9.  It may be a good
idea to make this an errata update.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
No steps, just trying to help keep RedHat a nice, modern, usable and STABLE
system.    

Actual Results:  Depends on if I am right about XChat 2.0 being good enough for
inclusion.

Expected Results:  Would be nice to have it.

Additional info:
Comment 1 Mike A. Harris 2003-04-03 04:04:42 EST
>I noticed in Phoebe and Rawhide that xchat is still 1.8.11.  This doesn't seem
>right as Xchat 2.0 seems to have all features of 1.8.11 and is more up to date
>for the destkop.

During Red Hat Linux 9 development, xchat 2.x was *NOT* available until
*long* after our code freeze.  Red Hat does not throw in brand new random
software versions 10 minutes before we go gold.  The purpose of releasing
beta tests of the distribution, is to have software tested and get feedback
and bug reports, and fix as many problems as possible before the next beta
release, and the next, and before the final gold release.  If you cram new
software versions into the distribution up until the final day, then you
get zero beta testing, since you are throwing away the beta testing that was
done on that software when you replace it with a major new version.

>I am sure there might be reason with some software to not
>include updated versions

You are correct, and xchat is not an exception.

>however, Xchat does seem to be stable and does seem to
>have released 2.0 (in february) in time for release in RH9

Wrong.  It was not released anywhere near the time it would have had to
be released in order to get into Red Hat Linux 9.  During the creation
of Red Hat Linux there are specific dates that freezes occur on, and
once a certain date has occured, certain software versions are locked
in stone.  As time goes on, other software is locked in stone.  The
software must get public beta testing, and as such, some software *must*
get into the distribution *before* the first public beta.  Other software
before the second beta, and other software before the third beta.

In order to consider updating any piece of software, it must also meet a
number of other criterion, both Red Hat policies, as well as developer
discretions.

xchat 2.0 was not released in time to be even remotely considered for
inclusion.

As the xchat maintainer here, and an xchat user whom has it running 24/7,
I can assure you that xchat 2.x will be included in the distribution at a
future time.  That may be as an enhancement, or it might wait until the next
distribution release depending on many factors.

There is no need for me to track this in bugzilla, as it will "just happen"
when I feel the time is right.  Proper quality assurance matters more to me
than flashy version number changes with zero testing.  Watch Red Hat rawhide
if you want to know when it gets first included in the distro.  I don't
expect it will be long.  It definitely wont be enhancement erratum anytime
soon though.

Closing NOTABUG.




Comment 2 Mike A. Harris 2003-04-10 14:18:08 EDT
*** Bug 88427 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2003-05-29 19:40:56 EDT
xchat 2.0.2 has been in rawhide for a while now.

Note You need to log in before you can comment on or make changes to this bug.