Bug 878545 - Remote-viewer: Dual monitor: Full-screen resolution set higher than native
Remote-viewer: Dual monitor: Full-screen resolution set higher than native
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 11:40 EST by Milan Barta
Modified: 2015-10-27 20:19 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 09:55:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remote-viewer --spice-debug (42.05 KB, text/plain)
2012-11-20 11:40 EST, Milan Barta
no flags Details
Xorg log (130.69 KB, text/plain)
2012-11-20 11:41 EST, Milan Barta
no flags Details
xrandr output (1.56 KB, text/plain)
2012-11-20 11:42 EST, Milan Barta
no flags Details

  None (edit)
Description Milan Barta 2012-11-20 11:40:11 EST
Created attachment 648676 [details]
remote-viewer --spice-debug

Description of problem:
This issue occurs with dual monitor set up.
When the remote-viewer is executed in window mode in order to connect to a VM (e.g. through RHEVM) and then switched to full-screen mode (using Shift+F11 or through RV menu), the full-screen resolution of guest system is set to a sum of both client monitor resolutions.
In my case the guest resolution is set to 2560x1024 (as I have two monitors 1280x1024 each).

This doesn't happen when remote-viewer is launched with --full-screen parameter. In this case the resolution in full-screen matches the client's one.

When tested with previous version of remote-viewer (virt-viewer-0.5.2-15.el6.x86_64) the issue didn't occur.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a dual monitor client machine set up
2. Set up a VM with one monitor and spice-vdagent running
3. Connect to it using remote-viewer in window mode
4. Switch to full-screen mode (Shift+F11)
  
Actual results:
The guest full-screen resolution is set to a sum of both client monitor resolutions but displayed over one monitor only.

Expected results:
The guest full-screen resolution is set to a value matching the native client monitor resolution.

Additional info:
Comment 1 Milan Barta 2012-11-20 11:41:33 EST
Created attachment 648678 [details]
Xorg log
Comment 2 Milan Barta 2012-11-20 11:42:00 EST
Created attachment 648679 [details]
xrandr output
Comment 6 Marc-Andre Lureau 2013-05-09 11:27:45 EDT
I can't reproduce.

What is the guest?

Can you try against current virt-viewer-0.5.2-18.el6_4.2.x86_64 ? It has some multi-monitor fixes.

thanks
Comment 7 Milan Barta 2013-05-15 06:14:41 EDT
I've tested on both Windows and RHEL guests and looks like the bug's been fixed in virt-viewer-0.5.2-18.el6_4.2.

I suppose the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.