Bug 878561 - plexus-active-collections: Remove/replace (build)requires on plexus-container-default
plexus-active-collections: Remove/replace (build)requires on plexus-container...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plexus-active-collections (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 12:00 EST by Stanislav Ochotnicky
Modified: 2012-12-11 19:19 EST (History)
3 users (show)

See Also:
Fixed In Version: plexus-active-collections-1.0-0.9.beta2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 07:11:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2012-11-20 12:00:30 EST
Your package plexus-active-collections either requires or buildrequires plexus-container-default. This package contains old API which is not commonly used and has not contained maven dependency mappings since September 2011. It means that unless your package is using custom dependency map to build, it is not using plexus-container-default. 

In most cases your package is instead using 'plexus-containers-container-default' package. If any pom.xml files contain reference to groupId:artifactId org.codehaus.plexus:plexus-container-default you can replace plexus-container-default with plexus-containers-container-default. If your pom.xml files don't reference mentioned groupId:artifactId it should be safe to remove completely
Comment 1 Fedora Update System 2012-11-27 10:48:59 EST
plexus-active-collections-1.0-0.9.beta2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/plexus-active-collections-1.0-0.9.beta2.fc18
Comment 2 Fedora Update System 2012-12-11 19:19:43 EST
plexus-active-collections-1.0-0.9.beta2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.