Bug 87858 - (IDE IDE-FLOPPY)ide zip-100 problems
(IDE IDE-FLOPPY)ide zip-100 problems
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 02:54 EST by Dmitri A. Sergatskov
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2003-04-03 02:54:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
I have two computers one UP and one SMP (both athlons) with internal ide zip-100
and both of them has some problem with it. Just mounting and unmounting the
drive results in error messages in /var/log/messages:

 localhost kernel: ide-floppy: CoD != 0 in idefloppy_pc_intr
 localhost kernel: hdg: ATAPI reset complete
 localhost kernel: ide-floppy: CoD != 0 in idefloppy_pc_intr
 localhost kernel: hdg: ATAPI reset complete
 localhost kernel: ide-floppy: CoD != 0 in idefloppy_pc_intr
 localhost kernel: hdg: ATAPI reset complete
 localhost kernel:  hdg: hdg4

While UP computer usually survive it (i.e. everything seems 
to be working inspite of errors), the SMP usually hangs
hard -- power cycle required.

Attempt to write to zip (or re-format it) makes a flury of the same errors and
sometimes (not 100% reproducible):

 localhost kernel: ide-floppy: CoD != 0 in idefloppy_pc_intr
 localhost kernel: hdg: ATAPI reset complete
 localhost kernel: ide-floppy: possible ide-floppy.c bug - Two request sense in
serial were issued
 localhost kernel: ide-floppy: hdg: I/O error, pc =  0, key =  2, asc = 3a, ascq
=  0
 localhost kernel: ide-floppy: hdg: I/O error, pc = 1b, key =  2, asc = 3a, ascq
=  0

Those were seen on both UP and SMP computers and SMP hangs again.
(I have yet to try "noacpi" option on smp system)
 

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1.plug zip into internal ide zip100 drive
2.as root: tail -f /var/log/messages
3.mount /mnt/zip
or
3. (as root) mkfs.ext2 /dev/hdg4

    

Actual Results:  Errors in /var/log/messages or computer hangs

Expected Results:  No eroors

Additional info:

UP computer: Shuttle AK32S / AthlonXP 2000+ / Maxtor Ultra100 ide contr
SMP: Tyan S2460 (amd-760) / AthlonMP 2000+ / Maxtor Ultra100 ide contr

both computers worked fine with rh8.0
Comment 1 Dmitri A. Sergatskov 2003-04-03 22:17:48 EST
I played more with zip. Neither 'noacpi' nor booting into UP mode  changed
anything. I managed to 'solve' the problem by adding a second jumper to
zip drive (following 'A' configuration on the Zip sticker -- nothing
about this in any of my manuals):

Was:   (...50-pin...) o o X ( power )
Now:   (...50-pin...) o X X ( power )

That switched the drive into pio0 mode (was pio2) and I do not see any errors 
so far...

Hope this is of some help.
Comment 2 Alan Cox 2003-06-05 12:49:00 EDT
What IDE controller are they attached to >
Comment 3 Dmitri A. Sergatskov 2003-06-05 13:08:43 EDT
They are both Maxtor (Promise OEM) controllers.
The one in Tyan box is "Ultra100" (older) and in Shuttle "Ultra133".
Tyan used to have RH8.0 installed and it worked fine. 
 
[dima@tumbleweed dima]$ /sbin/lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP
Bridge00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ISA
(rev 02)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] IDE (rev 01)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ACPI (rev 01)
00:07.4 USB Controller: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] USB
(rev 07)
00:09.0 Unknown mass storage controller: Promise Technology, Inc. 20267 (rev
02)00:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
00:0d.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD [Radeon
64 DDR]
[dima@tumbleweed dima]$ cat /proc/interrupts
           CPU0       CPU1
  0:    6816718    6847340    IO-APIC-edge  timer
  1:       4933       4730    IO-APIC-edge  keyboard
  2:          0          0          XT-PIC  cascade
  8:          1          0    IO-APIC-edge  rtc
 12:     277637     265529    IO-APIC-edge  PS/2 Mouse
 14:      64500      72240    IO-APIC-edge  ide0
 15:       3962       4054    IO-APIC-edge  ide1
 16:     396288     396986   IO-APIC-level  eth0
 17:    1356300    1365171   IO-APIC-level  ide2, ide3, es1371
 18:    5851339    5811847   IO-APIC-level  radeon@PCI:1:5:0
 19:          0          0   IO-APIC-level  usb-ohci
NMI:          0          0
LOC:   13664389   13664387
ERR:          0
MIS:          0

Comment 4 Jack Tanner 2003-10-20 00:11:03 EDT
Same problem as original poster. I also have a Promise Ultra133 TX2. By the
looks of googling around, this is a frequently occuring, unfrequently solved
problem.
Comment 5 Bugzilla owner 2004-09-30 11:40:44 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.