This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 878644 - Review Request: openshift-origin-broker-util -Utility scripts for the OpenShift Origin broker
Review Request: openshift-origin-broker-util -Utility scripts for the OpenShi...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Scherer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 15:49 EST by Troy Dawson
Modified: 2013-01-11 20:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:23:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
misc: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2012-11-20 15:49:11 EST
Spec URL: http://tdawson.fedorapeople.org/openshift-origin/openshift-origin-broker-util.spec
SRPM URL: http://tdawson.fedorapeople.org/openshift-origin/openshift-origin-broker-util-1.1.8-2.fc18.src.rpm
Description: This package contains a set of utility scripts for the openshift broker. They must be run on a openshift broker instance.
Fedora Account System Username: tdawson maxamillion

RPMLINT OUTPUT:
$ rpmlint openshift-origin-broker-util.spec openshift-origin-broker-util-1.1.8-2.fc18.src.rpm openshift-origin-broker-util-1.1.8-2.fc18.noarch.rpm
2 packages and 1 specfiles checked; 0 errors, 0 warnings.
Comment 1 Michael Scherer 2012-11-22 10:23:08 EST
After reading the code, I have 3 remarks :
- /tmp usage is IMHO to be avoided ( https://github.com/openshift/origin-server/pull/507 )

- there is a few missing requires :
host and nsupdate would need bind-utils rpm ( used in oo-register-dns among others )
curl need curl rpm ( used oo-accept-broker )
rngd is not pulled anywhere, but used in some script ( oo-setup-bind )
openssl is used to create certificate in oo-setup-broker , so should be required

- requires is wrong :
Requires:       openshift-broker
in fedora, that's openshift-origin-broker
Comment 2 Troy Dawson 2012-11-27 13:42:42 EST
Spec URL: http://tdawson.fedorapeople.org/openshift-origin/openshift-origin-broker-util.spec
SRPM URL: http://tdawson.fedorapeople.org/openshift-origin/openshift-origin-broker-util-1.1.8-3.fc18.src.rpm

Tmp
 working on merging that in.  It should be in the next release.

Requires:
 bind-utils - added
 curl - not added (needed by rpm, should be installed by default)
 rng-tools - added
 openssl - added
 openshift-broker - changed to openshift-origin-broker
Requesting to have these requires merged upstream
https://github.com/openshift/origin-server/pull/981
Comment 3 Michael Scherer 2012-12-06 16:22:14 EST
Package is good, except it doesn't fully work, see bug 884860 for issue in dependant rpms. 

And it should be updated to the latest version.

But I consider this is not blocking, so I will approve it ( as the issues are not in this package, but others one )

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[!]: Latest version is packaged.
[!]: Package functions as described.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[!]: Package functions as described.
[!]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: openshift-origin-broker-util-1.1.8-3.fc18.noarch.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint openshift-origin-broker-util
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
openshift-origin-broker-util (rpmlib, GLIBC filtered):
    /bin/bash
    /bin/sh
    /usr/bin/env
    bind-utils
    openshift-origin-broker
    openssl
    rng-tools
    ruby(abi)



Provides
--------
openshift-origin-broker-util:
    openshift-origin-broker-util



MD5-sum check
-------------
http://mirror.openshift.com/pub/openshift-origin/source/openshift-origin-broker-util/openshift-origin-broker-util-1.1.8.tar.gz :
  CHECKSUM(SHA256) this package     : 9757d7447e94cd5031f3af0de00e4bcaac44c3cd71a525fd3d1c6edef8e3d659
  CHECKSUM(SHA256) upstream package : 9757d7447e94cd5031f3af0de00e4bcaac44c3cd71a525fd3d1c6edef8e3d659


Generated by fedora-review 0.2.0 (Unknown) last change: Unknown
Buildroot used: fedora-18-x86_64
Command line :./try-fedora-review -b 878644
Comment 4 Troy Dawson 2012-12-06 16:45:45 EST
Thank you for the approval.

1.1.8 is the latest stable release.  The 1.2.x branch is still in development/QA.

I will work on the bugzilla you mentioned.  Thank you for finding that bug.
Comment 5 Troy Dawson 2012-12-06 16:47:43 EST
New Package SCM Request
=======================
Package Name: openshift-origin-broker-util
Short Description: Utility scripts for the OpenShift Origin broker
Owners: tdawson maxamillion
Branches: f18 f17
InitialCC:
Comment 6 Jon Ciesla 2012-12-07 08:17:46 EST
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-12-07 10:33:24 EST
openshift-origin-broker-util-1.1.8-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openshift-origin-broker-util-1.1.8-3.fc18
Comment 8 Fedora Update System 2012-12-07 15:43:58 EST
openshift-origin-broker-util-1.1.8-3.fc18 has been pushed to the Fedora 18 testing repository.
Comment 9 Fedora Update System 2013-01-11 20:23:02 EST
openshift-origin-broker-util-1.1.8-3.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.