This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 878670 - Upgade F17 - F18 - keybord setings forgotten
Upgade F17 - F18 - keybord setings forgotten
Status: CLOSED DUPLICATE of bug 881785
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 17:07 EST by Flóki Pálsson
Modified: 2012-11-30 09:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 09:25:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2012-11-20 17:07:53 EST
Description of problem:
After upgrading from F17 to F18 then keyboard setting is forgotten.
In F17 there was Iclandic keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
I have only done it once.

Steps to Reproduce:
1.  Ugrade from F17 to F18
( se https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18 )
2.
3.
  
Actual results:
After upgrade and reboot. There seems to be US kyboard.


Expected results:
Icelandic keyboard.

Additional info:
I have to run system-config-keyboard to set Icelandic keyboard.
Comment 1 Will Woods 2012-11-21 16:56:22 EST
fedup doesn't touch the keyboard settings.

If there's a problem with the keyboard settings between the F17 and F18 packages, that needs to be handled by the packages that provide/use the keyboard settings.
Comment 2 David Jansen 2012-11-30 06:27:28 EST
I think this is due to the change in location of keyboard and i18n settings, see the Fedora 18 release notes. I ran into something similar too. Should indeed be handled by the packages that own these files.
Comment 3 Nicola Soranzo 2012-11-30 09:25:01 EST
The solution for the upgrade problem is now explained in the wiki page:

https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18

*** This bug has been marked as a duplicate of bug 881785 ***

Note You need to log in before you can comment on or make changes to this bug.