Bug 878735 - [abrt] gnome-online-accounts-3.6.2-1.fc18: Process /usr/libexec/goa-daemon was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-online-accounts-3.6.2-1.fc18: Process /usr/libexec/goa-daemon wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8e57ff10a4a222336864059252f...
: 903024 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-21 05:20 UTC by Amit Shah
Modified: 2013-09-05 07:34 UTC (History)
7 users (show)

Fixed In Version: gnome-online-accounts-3.8.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-01 23:03:15 UTC
Type: ---


Attachments (Terms of Use)
File: core_backtrace (1.21 KB, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: environ (1.08 KB, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: backtrace (27.50 KB, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: cgroup (127 bytes, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: executable (23 bytes, text/plain)
2012-11-21 05:20 UTC, Amit Shah
no flags Details
File: maps (52.71 KB, text/plain)
2012-11-21 05:21 UTC, Amit Shah
no flags Details
File: dso_list (10.80 KB, text/plain)
2012-11-21 05:21 UTC, Amit Shah
no flags Details
File: proc_pid_status (916 bytes, text/plain)
2012-11-21 05:21 UTC, Amit Shah
no flags Details
File: open_fds (788 bytes, text/plain)
2012-11-21 05:21 UTC, Amit Shah
no flags Details
File: var_log_messages (675 bytes, text/plain)
2012-11-21 05:21 UTC, Amit Shah
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 699491 0 None None None Never

Description Amit Shah 2012-11-21 05:20:19 UTC
Description of problem:
Create an account for kerberos login.  It didn't automatically log in, so I opened the online accounts settings tab and clicked on the account.  This appeared a while later.

Version-Release number of selected component:
gnome-online-accounts-3.6.2-1.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/libexec/goa-daemon
crash_function: goa_identity_service_identity_get_expiration_timestamp
kernel:         3.6.7-1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (6 frames)
: #0 goa_identity_service_identity_get_expiration_timestamp at ../../src/goaidentity/org.gnome.Identity.c:1649
: #1 ensure_credentials_sync at goakerberosprovider.c:1855
: #2 ensure_credentials_in_thread_func at goaprovider.c:412
: #3 run_in_thread at gsimpleasyncresult.c:869
: #4 io_job_thread at gioscheduler.c:162
: #6 g_thread_proxy at gthread.c:797

Comment 1 Amit Shah 2012-11-21 05:20:26 UTC
Created attachment 649031 [details]
File: core_backtrace

Comment 2 Amit Shah 2012-11-21 05:20:30 UTC
Created attachment 649032 [details]
File: environ

Comment 3 Amit Shah 2012-11-21 05:20:33 UTC
Created attachment 649033 [details]
File: limits

Comment 4 Amit Shah 2012-11-21 05:20:40 UTC
Created attachment 649034 [details]
File: backtrace

Comment 5 Amit Shah 2012-11-21 05:20:46 UTC
Created attachment 649035 [details]
File: cgroup

Comment 6 Amit Shah 2012-11-21 05:20:53 UTC
Created attachment 649036 [details]
File: executable

Comment 7 Amit Shah 2012-11-21 05:21:03 UTC
Created attachment 649037 [details]
File: maps

Comment 8 Amit Shah 2012-11-21 05:21:22 UTC
Created attachment 649038 [details]
File: dso_list

Comment 9 Amit Shah 2012-11-21 05:21:25 UTC
Created attachment 649039 [details]
File: proc_pid_status

Comment 10 Amit Shah 2012-11-21 05:21:28 UTC
Created attachment 649040 [details]
File: open_fds

Comment 11 Amit Shah 2012-11-21 05:21:32 UTC
Created attachment 649041 [details]
File: var_log_messages

Comment 12 Kamil Páral 2013-02-11 10:56:26 UTC
I can easily reproduce this crash by moving the "Network Resources" slider in GOA to OFF and ON again.

Comment 13 Roman Kagan 2013-04-04 06:40:03 UTC
Me too, with gnome-online-accounts-3.6.3-1.fc18.x86_64.

Repro:

1) start goa-daemon when tgt already exists (e.g. by taking it over from a running goa-daemon)

# /usr/libexec/goa-daemon --replace

2) destroy the tgt

# kdestroy

voila, goa-daemon segfaults.

Comment 14 Debarshi Ray 2013-08-28 13:20:17 UTC
*** Bug 903024 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2013-08-30 12:21:35 UTC
gnome-online-accounts-3.8.3-1.fc19,gnome-documents-3.8.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-online-accounts-3.8.3-1.fc19,gnome-documents-3.8.4-1.fc19

Comment 16 Fedora Update System 2013-08-30 22:57:12 UTC
Package gnome-online-accounts-3.8.3-1.fc19, gnome-documents-3.8.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-online-accounts-3.8.3-1.fc19 gnome-documents-3.8.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15556/gnome-online-accounts-3.8.3-1.fc19,gnome-documents-3.8.4-1.fc19
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2013-09-01 23:03:15 UTC
gnome-online-accounts-3.8.3-1.fc19, gnome-documents-3.8.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Roman Kagan 2013-09-05 07:34:34 UTC
As noted in the upstream bug, the updated version doesn't crash indeed but it doesn't do what it's supposed to (it doesn't create and refresh the tgt without user interaction).

So the fix is incomplete; the upstream bug has been reopened.


Note You need to log in before you can comment on or make changes to this bug.