Bug 878758 - rhn_register shows link to https://rhn.redhat.com/rhn/sales/LoginInfo.do
Summary: rhn_register shows link to https://rhn.redhat.com/rhn/sales/LoginInfo.do
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Milan Zázrivec
QA Contact: Pavel Studeník
URL:
Whiteboard:
: 882934 (view as bug list)
Depends On:
Blocks: 881827
TreeView+ depends on / blocked
 
Reported: 2012-11-21 07:28 UTC by Jan Pazdziora
Modified: 2013-02-21 10:07 UTC (History)
2 users (show)

Fixed In Version: rhn-client-tools-1.0.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:07:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0388 0 normal SHIPPED_LIVE rhn-client-tools bug fix and enhancement update 2013-02-20 20:51:47 UTC

Description Jan Pazdziora 2012-11-21 07:28:25 UTC
Description of problem:

When running rhn_register, on the Enter you account information page it says:

   ┌───────────────────┤ Enter you account information ├────────────────────┐
   │                                                                        │ 
   │ Please enter your login information for Red Hat Network                │ 
   │ (http://rhn.redhat.com/):                                              │ 
   │                                                                        │ 
   │                  Red Hat Login: ____________________                   │ 
   │                       Password: ____________________                   │ 
   │ Tip: Forgot your login or password? Visit:                             │ 
   │ https://rhn.redhat.com/rhn/sales/LoginInfo.do                          │ 

When I go to that URL, I'm first asked for my login and password (not very useful), and when I actually log in, I get

Classic Subscription Management
No systems selected [ Manage | Clear ]
error Page Not Found

The page you requested, /rhn/sales/LoginInfo.do, was not found.

    If you typed this address into your browser, double-check the spelling and capitalization. The address you are copying may also be outdated.
    If you followed a link to reach '/rhn/sales/LoginInfo.do,' the link may be incorrect or outdated. Click on the back button in your browser to try a different link, or use the top (or left) navigation bars to find the page you are looking for.
    If you used a bookmark to reach '/rhn/sales/LoginInfo.do,' the page may have moved to a different location since the bookmark was created. Use the top (or left) navigation bars to find the page you are looking for, and if you find the document be sure to update your bookmark.
    If you feel you've reached this page in error, please contact us with details of how you received this message.

Version-Release number of selected component (if applicable):

rhn-setup-1.0.0-87.el6.noarch
rhn-client-tools-1.0.0-87.el6.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Run rhn_register.
2. Get to that Enter you account information page.
3. Follow the LoginInfo.do link.
  
Actual results:

Page Not Found

Expected results:

Something useful or no link at all.

Additional info:

Comment 1 Milan Zázrivec 2012-11-21 10:10:30 UTC
satellite.git CLIENT-RHEL-6: b6923907dd25934dacfd91c3ff046aabd729a0f2

Comment 5 Milan Zázrivec 2012-12-03 12:19:22 UTC
*** Bug 882934 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2013-02-21 10:07:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0388.html


Note You need to log in before you can comment on or make changes to this bug.