This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 878891 - [RFE] listing activation keys (1+) on system info in better way (close to each other - not a new line for each)
[RFE] listing activation keys (1+) on system info in better way (close to eac...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
: FutureFeature
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-21 08:30 EST by Garik Khachikyan
Modified: 2016-04-25 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:53:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ak list (72.06 KB, image/png)
2012-11-21 08:30 EST, Garik Khachikyan
no flags Details
Activation keys visible in formatted way (48.65 KB, image/png)
2013-08-07 04:40 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Garik Khachikyan 2012-11-21 08:30:42 EST
Created attachment 649222 [details]
ak list

Description of problem:
Recent implementation of displaying activation keys in "System->Details->System info" looks a little bit odd: each key in a new line. Suggesting make it next to each other...

Version-Release number of selected component (if applicable):
candlepin-0.7.19-1.el6_3.noarch
candlepin-cert-consumer-hp-magnycours-02.rhts.eng.bos.redhat.com-1.0-1.noarch
candlepin-tomcat6-0.7.19-1.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-cli-1.2.4-2h.el6_3.noarch
katello-cli-common-1.2.4-2h.el6_3.noarch
katello-common-1.2.6-2h.el6_3.noarch
katello-configure-1.2.3-1h.el6_3.noarch
katello-glue-candlepin-1.2.6-2h.el6_3.noarch
katello-headpin-1.2.6-2h.el6_3.noarch
katello-headpin-all-1.2.6-2h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-isodate-0.4.4-4.pulp.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
python-qpid-0.14-11.el6_3.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
rubygem-ldap_fluff-0.1.3-1.el6_3.noarch
thumbslug-0.0.27-1.el6_3.noarch
thumbslug-selinux-0.0.27-1.el6_3.noarch

How reproducible:
always

Steps to Reproduce:
1.make 3 ak-s and register a system with --atcivation_key k1,k2,k3
2.refer to SAM 1.2 UI and go to System->Details->System Info
3.
  
Actual results:
keys are listed each in a new line

Expected results:
to be listed close to each other - same line (wrap only if there is not much space maybe?)

Additional info:
see attachment
Comment 1 Tom McKay 2012-12-18 12:25:49 EST
https://github.com/Katello/katello/pull/1294
Comment 2 Tom McKay 2013-01-07 11:03:55 EST
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 53422ef44e379ce476a92c4adb9ba6fbb282ca2e
      https://github.com/Katello/katello/commit/53422ef44e379ce476a92c4adb9ba6fbb282ca2e
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-12-18 (Tue, 18 Dec 2012)
Comment 3 Bryan Kearney 2013-06-06 16:50:10 EDT
Moving all POST / MODIFIED bugs to ON_QA due to the new builds.
Comment 4 Tazim Kolhar 2013-08-07 04:40:26 EDT
Created attachment 783742 [details]
Activation keys visible in formatted way

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-common-1.4.3-5.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-cli-common-1.4.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
katello-headpin-all-1.4.3-5.el6sam_splice.noarch
katello-cli-1.4.3-4.el6sat.noarch
katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-5.el6sam_splice.noarch
Comment 6 errata-xmlrpc 2013-10-01 06:53:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.