Bug 878893 - rhncfg-client diff failed when file wasn't deployed on system
rhncfg-client diff failed when file wasn't deployed on system
Status: CLOSED DUPLICATE of bug 879299
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-11-21 08:32 EST by Pavel Studeník
Modified: 2012-12-03 05:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 05:43:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2012-11-21 08:32:19 EST
Description of problem:
I run command  "rhncfg-client diff" when files wasn't deployed on system and application failed.

Version-Release number of selected component (if applicable):
rhncfg-client-5.10.27-8.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Create and subscribe system to configuration channel
2. Add new file to this configuration channel
3. Before the file was deployed, run command rhncfg-client diff
4. rhncfg-client failed with error "UnboundLocalError: local variable 'statinfo' referenced before assignment"
  
Actual results:
>> rhncfg-client diff
  File "/usr/bin/rhncfg-client", line 38, in <module>
    sys.exit(Main().main() or 0)
  File "/usr/share/rhn/config_common/rhn_main.py", line 195, in main
    handler.run()
  File "/usr/share/rhn/config_client/handler_base.py", line 66, in run
    self._process_file(src, dst, file, ftype, file_info)
  File "/usr/share/rhn/config_client/rhncfgcli_diff.py", line 53, in _process_file
    (self.options.display_diff or get_config('display_diff')))))
  File "/usr/share/rhn/config_common/file_utils.py", line 161, in diff
    (dst_content, dst_name, dst_time, dst_stat) = f_content(dst, dstname)
  File "/usr/share/rhn/config_common/file_utils.py", line 158, in f_content
    return (content, name, f_time, statinfo)
UnboundLocalError: local variable 'statinfo' referenced before assignment


Expected results:
Without error and get correct diff of files.

Additional info:
Package rhncfg-client-5.9.27-17.el6.noarch.rpm worked correctly.
Comment 1 Michael Mráka 2012-12-03 05:43:11 EST

*** This bug has been marked as a duplicate of bug 879299 ***

Note You need to log in before you can comment on or make changes to this bug.