Bug 87894 - gdm and kdm login problem with NIS remotely in xdmcp
gdm and kdm login problem with NIS remotely in xdmcp
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 11:14 EST by Vincent Fortier
Modified: 2015-01-07 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 12:05:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Fortier 2003-04-03 11:14:51 EST
Description of problem:
I've configured XFree to allow remote login from old HP Envizex II x terminals.
 I've used http://www.tldp.org/HOWTO/XDMCP-HOWTO/procedure.html to configure my
Xserver.  Almost everything is working:
On the console (run-lvl 5):
- I can log in has root or any NIS user
- I can do su - (from root to any nis user)

On a X terminal station connected to my X server:
- I can log in has root ONLY
- I can't log in has any NIS user.. here is the actual error message from
/var/adm/messages:
messages:Apr  1 16:22:57 rh-test gdm(pam_unix)[6882]: session opened for user
fortierv by (uid=0)
messages:Apr  1 16:22:57 rh-test automount[852]: attempting to mount entry
/home/fortierv
messages:Apr  1 16:22:57 rh-test gdm(pam_unix)[6882]: session closed for user
fortierv
and the error message from Xfree86 log file (i've masked my IP):
XFree86.0.log:AUDIT: Tue Apr  1 16:40:43 2003: 7499 X: client 6 rejected from IP
aaa.bbb.ccc.ddd port 38536

note:  My /home/* directories are automounted.. and always worked properly
directly on the console or by invoking su command.

Version-Release number of selected component (if applicable):
XFree86-4.2.0-8
XFree86-xdm-4.2.0-8
ypbind-1.10-7
pam-0.75-46.7.3


How reproducible:
I've configured my X server to allow remote connections with
http://www.tldp.org/HOWTO/XDMCP-HOWTO/procedure.html on a 7.2 server and a 7.3
server and had the same problem on both.

Steps to Reproduce:
1. Configure the X server with
http://www.tldp.org/HOWTO/XDMCP-HOWTO/procedure.html manual
2. Boot your envizex x terminal and log on your server with a nis user name
3.
    
Actual results:


Expected results:
will allow root login
won't allow login from nis user

Additional info:
I've tried to log in with different type of old hp envizex machines (700rx,
envizex II, etc.) and all did the same on both my 7.2 and 7.3 redhat servers.

Theses 2 server where installed with dell "installer" (they are 2450 and 2550
servers).  The symptom was the same with either a fresh 7.2 or 7.3 install or an
updated one with up2date (rhn network) (up2date done this week..).

thnx
Comment 1 Vincent Fortier 2003-04-16 14:52:39 EDT
I've made a few tries by changing the value of /etc/sysconfig/desktop
DISPLAYMANAGER="KDE" to use KDE 3 (on linux 7.3) instead of gdm and I'm having
exactly the same problem by being unaccepted by pam.d
Comment 2 Tomas Mraz 2004-11-16 12:05:58 EST
It doesn't seem to me to be a PAM bug. Could you retest with latest
Fedora Core and reopen if still there?

Note You need to log in before you can comment on or make changes to this bug.