Bug 878962 - [admin-portal] [UX] unable to see direct lun disk after create and attach since default disk view is set to images
[admin-portal] [UX] unable to see direct lun disk after create and attach sin...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.5.0
Assigned To: Tal Nisan
Ori Gofen
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 11:39 EST by Haim
Modified: 2016-05-25 21:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-16 14:10:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of dl disk. (171.52 KB, image/png)
2012-11-21 11:41 EST, Haim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 31770 master MERGED webadmin: In disks tab/subtab, make the default view to All Never
oVirt gerrit 31874 ovirt-engine-3.5 MERGED webadmin: In disks tab/subtab, make the default view to All Never

  None (edit)
Description Haim 2012-11-21 11:39:10 EST
Description of problem:

unable to see direct lun disk after create and attach since default disk view is set to images.

I would start by saying it took me more then a minute to find my disks, and I created several since I thought they were not created, its not clear at all that view is divided to disk types, and to me its a bad user experience.

repro steps:

1) create vm
2) create regular disk
3) create direct lun disk and mark attach button,
4) grid doesn't contain new disk
Comment 1 Haim 2012-11-21 11:41:08 EST
Created attachment 649303 [details]
screen shot of dl disk.
Comment 2 Simon Grinberg 2012-12-24 13:00:48 EST
Disks by default should show all if there are both types of disk present.

If it's too complex to decide on default view based on existing images/LUNs then always show all. Though you loos some information doing that.
Comment 6 Allon Mureinik 2014-08-04 05:46:18 EDT
(In reply to Simon Grinberg from comment #2)
> Disks by default should show all if there are both types of disk present.
> 
> If it's too complex to decide on default view based on existing images/LUNs
> then always show all. Though you loos some information doing that.
The default should be all. This isn't an RFE, it's a bug.
Comment 7 Allon Mureinik 2014-08-31 03:56:24 EDT
Tal, patch 31874 is merged to ovirt-engine-3.5.
Can this BZ be moved to MODIFIED?
Comment 9 Ori Gofen 2014-09-10 05:02:41 EDT
verified on rhevm vt2.2
Comment 10 Allon Mureinik 2015-02-16 14:10:45 EST
RHEV-M 3.5.0 has been released, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.