Bug 879046 - MacBookPro i7:EFI boot of TC-1 dd live-desktop USB: Anaconda does not create a bootable USB HD after install finishes
Summary: MacBookPro i7:EFI boot of TC-1 dd live-desktop USB: Anaconda does not create ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mactel-boot
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Matthew Garrett
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F18Blocker, F18FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2012-11-21 22:38 UTC by satellitgo
Modified: 2012-12-17 11:21 UTC (History)
11 users (show)

Fixed In Version: mactel-boot-0.9-8.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-17 11:21:11 UTC


Attachments (Terms of Use)

Description satellitgo 2012-11-21 22:38:46 UTC
Description of problem:
MacBookPro i7:EFI boot of RC1 dd live-desktop USB: Anaconda does not create a bootable USB HD  after install finishes

Version-Release number of selected component (if applicable):
dd USB of RC1-live-desktop x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
GUID Partition table
Installed Hd has 
HFS/HFS+ partition    /dev/sdb1
ext4                  /dev/sdb2
LVM2 Physical volume  /dev/sdb3

Comment 1 Chris Lumens 2012-11-26 15:48:59 UTC
Please attach /tmp/syslog (/var/log/syslog on live installs I believe), /tmp/anaconda.log, /tmp/program.log, and /tmp/storage.log to this bug report as separate uncompressed files.  Thanks.

Comment 2 satellitgo 2012-12-08 23:40:59 UTC
also occurs with f18 TC-1 DVD x86_64 dd 8 GB USB
Unable to get logs -

Comment 3 Matthew Garrett 2012-12-09 01:02:38 UTC

*** This bug has been marked as a duplicate of bug 873629 ***

Comment 4 Matthew Garrett 2012-12-09 02:34:57 UTC
https://admin.fedoraproject.org/updates/mactel-boot-0.9-8.fc18 should fix this.

Comment 5 Adam Williamson 2012-12-11 06:18:16 UTC
Proposing as blocker - mjg59 says "<mjg59> nirik: I doubt it's massively urgent (and I haven't poked adamw about it) but installs on Macs will fail until the new mactel-boot migrates"

it is kinda urgent, we don't want to bork all Mac installs.

Comment 6 Adam Williamson 2012-12-12 17:39:03 UTC
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Accepted as a blocker per criterion "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode..." on Macs.

Comment 7 Adam Williamson 2012-12-12 18:14:38 UTC
Correction to above: discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt , not 12-10.

Comment 8 Jaroslav Reznik 2012-12-13 09:36:02 UTC
Changing bug status to MODIFIED to better reflect current status as reported in comment #4.

Comment 9 Adam Williamson 2012-12-14 00:27:05 UTC
TC2 should include this fix, so please test it and leave karma.

Comment 10 satellitgo 2012-12-15 22:42:30 UTC
This worked correctly in a EFI booted dd-TC-2 DVD x86_64. anaconda intalled to an external USB HD from my MacbookPro i7 USB 
Boot of External USB HD shows a Fedora Icon to right of Mac HD on "option" boot and works.

Unfortuanatly neither wired or wireless connections are recognized.

A better solution is to use VirtualBox on the Mac with sugar where networking works.

Comment 11 Josef Skladanka 2012-12-17 10:07:28 UTC
Both DVD and Live Desktop worked correctly on Mac Mini.

Comment 12 Kamil Páral 2012-12-17 11:21:11 UTC
Anaconda 18.37.2 is stable, closing.


Note You need to log in before you can comment on or make changes to this bug.